Statische Seite -- Inhalt wird nicht dargestellt

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
LosMintos
Posts: 3
Joined: Fri Oct 14, 2011 1:35 pm

Statische Seite -- Inhalt wird nicht dargestellt

Post by LosMintos » Fri Oct 14, 2011 1:43 pm

Hi,

in einer neuen Serendipity-Installation (Serendipity 1.5.5 und PHP 5.2.4-2ubuntu5.17) habe ich das Ereignis-Plugin "Statische Seiten" (v 3.87) und das Seitenleisten-Plugin "Statische Seiten" (v. 1.17) installiert. Ich habe eine statische Seite erzeugt, Inhalt angelegt und u.a. diese Einstellungen getroffen:

Permalink: impressum.html
Artikeltyp: Article
Elternseite: Ist Elternseite
Artikelstatus: Veröffentlichung

Auf dem Blog erscheint in der Seitenleiste eine Box "Statische Seiten" mit einem Link zur Startseite und einem Link "Impressum". Die Links funktionieren, aber auf der statischen Seite wird nicht der gedachte Inhalt angezeigt, sondern der gleiche Inhalt wie auf der Startseite (Aufmacher des ersten Blogbeitrages). Nirgends ist der eigentliche Inhalt meiner statische Seite zu finden.

mod_rewrite funktioniert, die Seite (URL) wird ja auch angezeigt, nur der Inhalt ist der falsche.

Googlen bzw. die Suche hier, machten mich nicht schlauer.

Freue mich über Hinweise oder gar Lösungen! :-)

User avatar
yellowled
Regular
Posts: 7111
Joined: Fri Jan 13, 2006 11:46 am
Location: Eutin, Germany
Contact:

Re: Statische Seite -- Inhalt wird nicht dargestellt

Post by yellowled » Fri Oct 14, 2011 2:38 pm

LosMintos wrote:Freue mich über Hinweise oder gar Lösungen! :-)
Kann man sich das Ganze von außen ansehen (falls ja: URL?) oder ist das wieder eins von diesen hypergeheimen Blogs, die niemand lesen soll? Das verwendete Template wäre ggf. auch noch sachdienlich.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

LosMintos
Posts: 3
Joined: Fri Oct 14, 2011 1:35 pm

Re: Statische Seite -- Inhalt wird nicht dargestellt

Post by LosMintos » Fri Oct 14, 2011 2:50 pm

Ach so, nee, geheim ist das nicht
http://henning.fam-haida.de/

Welches Template? Gute Frage, bei Template-Optionen ist "blue" ausgewählt. Ich weiß nicht mehr genau, welches Template/welchen Style ich angeklickt habe (mein Fehler) :roll: Es ist jedenfalls ein "bulletproof". Der link "Templatedateien bearbeiten" führt zu templates/bulletproof_fork/.

User avatar
yellowled
Regular
Posts: 7111
Joined: Fri Jan 13, 2006 11:46 am
Location: Eutin, Germany
Contact:

Re: Statische Seite -- Inhalt wird nicht dargestellt

Post by yellowled » Fri Oct 14, 2011 4:01 pm

LosMintos wrote:Ach so, nee, geheim ist das nicht
Faszinierend. mod_rewrite funktioniert tatsächlich – die Links /admin/ und /archives/ funktionieren, aber die statische Seite (es geht um Impressum, richtig?) geht nicht.

Zeig mal die Einstellungen der statischen Seite (Screenshot oder so).

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

Freudi
Regular
Posts: 97
Joined: Thu Nov 23, 2006 6:29 am
Contact:

Re: Statische Seite -- Inhalt wird nicht dargestellt

Post by Freudi » Fri Oct 14, 2011 4:42 pm

LosMintos wrote:link: impressum.html
Hm, wie sieht's denn mit /impressum.html (also vorangestelltem Slash) aus?

Bye,
Freudi

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: Statische Seite -- Inhalt wird nicht dargestellt

Post by Timbalu » Fri Oct 14, 2011 6:04 pm

Hm, wie sieht's denn mit /impressum.html (also vorangestelltem Slash) aus?
würd ich auch sagen!
absoluter path ist vonnöten! (kann man testen, in dem man einen Phantasieordner hineinschreibt und sich dann nochmal den link in der sidebar anschaut.)
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

LosMintos
Posts: 3
Joined: Fri Oct 14, 2011 1:35 pm

Re: Statische Seite -- Inhalt wird nicht dargestellt

Post by LosMintos » Mon Oct 17, 2011 10:32 am

Hallo,

korrekt, der Permalink muss mit einem Slash beginnen, also /impressum.html.

Dummer Fehler, Danke für die Hilfe!

Post Reply