.htacces - mod_rewrite - Serendipity 0.8

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Matze_1
Posts: 4
Joined: Mon Apr 25, 2005 12:07 pm

.htacces - mod_rewrite - Serendipity 0.8

Post by Matze_1 » Mon Apr 25, 2005 12:24 pm

Hallo zusammen

wenn ich per mod_rewrite im Adminmenü die URL-Umformung anschalte dann funktioniert der Zugriff auf die CSS dateien nicht mehr.

Ich poste hier mal die Umgebung :

.htaccess:
# BEGIN s9y
ErrorDocument 404 /index.php
DirectoryIndex /index.php

RewriteEngine On
RewriteBase /
RewriteRule ^archives([/A-Za-z0-9]+)\.html index.php?url=/archives/$1.html [L,QSA]
RewriteRule ^([0-9]+)[_\-][0-9a-z_\-]*\.html index.php?url=$1-article.html [L,NC,QSA]
RewriteRule ^feeds/(.*) index.php?url=/feeds/$1 [L,QSA]
RewriteRule ^unsubscribe/(.*)/([0-9]+) index.php?url=/unsubscribe/$1/$2 [L,QSA]
RewriteRule ^approve/(.*)/(.*)/([0-9]+) index.php?url=approve/$1/$2/$3 [L,QSA]
RewriteRule ^delete/(.*)/(.*)/([0-9]+) index.php?url=delete/$1/$2/$3 [L,QSA]
RewriteRule ^(admin|entries)(/.+)? index.php?url=admin/ [L,QSA]
RewriteRule ^archive$ index.php?url=/archive [L,QSA]
RewriteRule ^categories/([0-9]+) index.php?url=/categories/$1 [L,QSA]
RewriteRule ^(index|atom|rss|b2rss|b2rdf).(rss|rdf|rss2|xml)$ rss.php?file=$1&ext=$2
RewriteRule ^plugin/(.*) index.php?url=plugin/$1 [L,QSA]
RewriteRule ^search/(.*) index.php?url=/search/$1 [L,QSA]
RewriteRule ^(serendipity\.css|serendipity_admin\.css) index.php?url=/$1 [L,QSA]
RewriteRule ^authors/([0-9]+) index.php?url=/authors/$1 [L,QSA]
RewriteRule ^index\.(html?|php.?) index.php?url=index.html [L,QSA]
RewriteRule ^htmlarea/(.*) htmlarea/$1 [L,QSA]
RewriteRule (.*\.html?) index.php?url=/$1 [L,QSA]

<Files *.tpl>
deny from all
</Files>

<Files *.sql>
deny from all
</Files>

<Files *.inc.php>
deny from all
</Files>

<Files *.db>
deny from all
</Files>

# END s9y



Hier die Fehlermeldung aus dem CGI-Debugger :

[Mon Apr 25 11:56:07 2005] [error] [client 193.194.145.207] File does not exist: /kunden/ich/blog3//serendipity_admin.css
und
[Mon Apr 25 11:55:32 2005] [error] [client 193.194.145.207] File does not exist: /kunden/ich/blog3//serendipity.css

Der volle Pfad in der Konfig ist:
/kunden/ich/blog3/

relativer http Pfad ist :
/

URL zum Blog ist :
http://blog.matthias-neugebauer.de/

index Datei ist :
index.php


Mod_rewrite an an sich funktioniert ja. Ich weiss nur nicht, wo der zweite Slash der in den Fehlermeldungen zu sehen ist herkommt. Das wird ja wohl das Problem sein.

Unter rewrite base habe ich schonmal blog3/ eingetragen
und den Slash in der konfig bei "relativer HTTP Pfad" habe ich auch schonmal rausgenommen. Leider hat es nichts gebracht.

Hat einer von Euch da schonmal Erfahrungen gesammelt.

Danke,

Matze

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: .htacces - mod_rewrite - Serendipity 0.8

Post by garvinhicking » Mon Apr 25, 2005 1:14 pm

Also für mich sieht das so aus als würde dein mod_rewrite dort garnicht funktionieren.

Nimm aus der .htaccess doch mal "ErrorDocument 404 /index.php" ganz raus und guck ob dann archives/ usw. noch funktioniert. Ich vermute nämlich eher dass hie rdas "Backup-404-Apache Errorhandling" zu Tragen kommt und mod_rewrite ganz ignoriert wird?

Wenn ich "http://blog.matthias-neugebauer.de/serendipity.css" aufrufe klappt das auch generell...

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

Matze_1
Posts: 4
Joined: Mon Apr 25, 2005 12:07 pm

Post by Matze_1 » Mon Apr 25, 2005 1:39 pm

Hi,

hatte eben mal das mod_rewrite wieder rausgenommen.

Habs wieder eingeschaltet (ich lass es jetzt mal so) und "ErrorDocument 404 /index.php" rausgenommen.

Die Seite wird angezeigt und die URLS sind OK.
"ErrorDocument 404 /index.php" wieder eingesetzt.

Nur die CSS kommt nicht.

Fehler im CGI-LOG :
Mon Apr 25 11:55:32 2005] [error] [client 193.194.145.207] File does not exist: /kunden/ich/blog3//serendipity.css

Die beiden Slashes verstehe ich nicht.

Gruss

Matthias

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Mon Apr 25, 2005 1:47 pm

Diese CGI-Meldung kann nur kommen, wenn mod_rewrite die Datei nicht "greift", vielleicht kannst Du da mal schauen. Notfalls per RewriteLogLevel mal ein paar Debugginglevel anschauen und gucken was da kommt?

Wenn ich die .css URL aufrufe klappt es soweit auch?!?

Der doppelte Slash kann daher kommen dass "/serendipity.css.php" aufgerufen wird, und das an Deinen Document_Root angehangen wird wenn Apache danach sucht. Aber "/kunden/ich/blog3" ist zum beispiel identisch zu "/kunden////////////ich///blog3". :)

Grßüe,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

Matze_1
Posts: 4
Joined: Mon Apr 25, 2005 12:07 pm

Post by Matze_1 » Mon Apr 25, 2005 2:19 pm

Hi,

RewriteLog dürfte nicht funktionieren, da ich keinen Zugriff auf die httpd.conf habe. Wenn ich das hätte, gäbe es wohl grössere Probleme ;-)

Laut Domainfactory sollte mod_rewrite aber klappen.

Um mod_rewrite zu aktivieren, brauchen Sie in die .htaccess nur
folgendes zu schreiben:

RewriteEngine On
RewriteRule usw. ...


die URLS werden ja auch "geändert".

Diese CGI-Meldung kann nur kommen, wenn mod_rewrite die Datei nicht "greift", vielleicht kannst Du da mal schauen.


Hast Du noch einen Tip wo ich nachsehen könnte´ob es "greift" (Ich bin nicht gerade ein Coder).

Ansonsten schalte ich es wieder aus.

Danke nochmal

Matze

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Mon Apr 25, 2005 2:35 pm

RewriteLog sollte aber eigentlich auch in der .htaccess funktionieren.

Ohne so ein Logfile kann ich leider nicht wirklich sagen, was schiefläuft. Vielleicht bei Domainfactory mal nett anfragen ob das temporär möglich ist. Die Jungs sind nett und auf Zack. :)

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

Matze_1
Posts: 4
Joined: Mon Apr 25, 2005 12:07 pm

Post by Matze_1 » Mon Apr 25, 2005 2:38 pm

Fehler gefunden :

Womit Du mich daran erinnerst, dass es vielleicht sinnvoll wäre, im Kundenmenü nachzusehen, ob der Pfad, auf den die Domain geroutet wird, nicht womöglich versehentlich mit einem / abgeschlossen wurde - auch dann gab's schon Probleme mit .htaccess-Dateien...


Habe das gescheckt und siehe da das wars.

Manchmal sieht man den Wald vor Bäumen nicht.

Danke nochmal

Matthias

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Mon Apr 25, 2005 2:52 pm

Kein Problem, schön dass es dann doch so einfach war. Viel Spaß dann! :)

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

callya
Regular
Posts: 122
Joined: Sat Apr 02, 2005 8:42 pm
Location: Hamburg / Germany
Contact:

Post by callya » Mon May 02, 2005 11:08 pm

Platz da... ich komme! :)

Wo ich gerade dabei bin, im Adminmenü diese mod rewrite Funktion umzustellen, bemerke ich, dass die "statischen Seiten" nicht mehr funktionieren.

Zum Beispiel http://juckiq.de/index.php?/pages/impressum.html !
Wenn ich das auf "use apache mod_rewrite" stehen habe, dann steht halt in der Adresszeile die URL, aber er linkt auf die index.php...?! :shock:

Genau das gleiche, mit der "Statistik".. wenn ich den direktlink zu meiner Statistik eingeben (webalizer), dann wird (seit dem ich den mod rewrite umgestellt habe) auf die index.php gelinkt.. vorher hatte ich die Funktion disabled!

Da ging das zwar auch nicht, dass wenn in einem Ordner eine index.html z.b. lag, dass man einfach nur /order eingegeben hat.. dafür hat sich die seite geöffnet, wenn man die URL ausgeschrieben hat.. (/ordner/index.html)

Nun rewritet er aber alles?!
Und eine .htaccess finde ich im /hauptordner aufm ftp auch nicht! (EDIT: sind doch da, hatte nur "hidden files" ausgeblendet! ;) )
(obwohl das kommt: Probiere die Datei /bla/bla2/bla3//.htaccess zu erstellen...Fertig)

hilfe.. :(

PS: habs im moment wieder disabled -> die seite geht also!

User avatar
Oliver
Regular
Posts: 178
Joined: Mon Jan 10, 2005 7:43 pm
Location: Herne, Germany
Contact:

Post by Oliver » Mon May 02, 2005 11:40 pm

Supi... jetzt habe ich meine Antwort gelöscht :?

Also nochmal: Ich hatte das gleiche Problem wie Du, habe dann aber mein altes Static-Page-Plugin von Romulus deinstalliert, per SPARTACUS mit

Statische Seite:
Zeigt eine statische Seite innerhalb des Blogs mit dem Blog-Design und allen Formatierungen
Author: Marco Rinck, Garvin Hicking, David Rolston; version: 1.7


ersetzt, nachdem ich den Inhalt der alten statischen Seiten gesichert und später 'neue' statische Seiten erstellt hatte. Die neue (modifizierte) Version basiert auch auf Romulus', funzt aber irgendwie (?) besser...
Image

callya
Regular
Posts: 122
Joined: Sat Apr 02, 2005 8:42 pm
Location: Hamburg / Germany
Contact:

Post by callya » Mon May 02, 2005 11:53 pm

Hab mein Post auch gelöscht! *lol* :D

Mh, so.. ist zwar nicht DAS Problem gewesen, wie bei dir... hat mich aber auf die Idee gebracht, das ich die statischen Seiten noch nicht editiert hatte.

Es muss natürlich heißen: /pages/bla.html
und nicht wie vorher /index.php?/pages/bla.html! ;)

Danke trotzdem für deine Hilfe!

Ein Fehler bleibt allerdings: Ich kann nicht auf meine Statistik zugreifen! :|
http://juckiq.de/usage/index.html

Wieso nicht?! :(

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Tue May 03, 2005 9:47 am

In jeden Unterordner der nicht mit Serendipity zu tun hat musst Du wenn du Mod_rewrite nutzt eine .htaccess erstellen mit dem Inhalt:

Code: Select all

RewriteEngine Off


Viele Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

callya
Regular
Posts: 122
Joined: Sat Apr 02, 2005 8:42 pm
Location: Hamburg / Germany
Contact:

Post by callya » Tue May 03, 2005 6:14 pm

danke hasi! :lol:

c-bc-o

Post by c-bc-o » Sun May 15, 2005 9:48 pm

Hallo,

ich habe hier das gleiche Problem - ein Unterordner lässt sich nicht anspringen, es wird immer ein 404 erzeugt und auf die Index-Page gesprungen. Ein "RewriteEngine Off " bringt rein gar nichts, weder in der .htaccess noch direkt in der Server-Config.. :?:

callya
Regular
Posts: 122
Joined: Sat Apr 02, 2005 8:42 pm
Location: Hamburg / Germany
Contact:

Post by callya » Sun May 15, 2005 10:05 pm

Hast du die .htaccess denn auch in dem Ordner angelegt, den du aufrufen willst?!

Post Reply