Suche funktioniert nicht

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
User avatar
robert
Regular
Posts: 1042
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Suche funktioniert nicht

Post by robert » Tue Sep 01, 2009 11:24 pm

Habe gestern auf die 1.5 Beta gewechselt. Seither kommt nach Eingabe eines Begriffs in die Suche folgende Fehlermeldung:

Code: Select all

Suche
    Die Suche konnte nicht wie gewünscht ausgeführt werden. Hinweis für den Administrator dieses Blogs: Dieser Fehler kann durch fehlende Index-Schlüssel der Datenbank verursacht werden. Auf MySQL-Systemen muss der Datenbankbenutzer-Account in der Lage sein, Index-Schlüssel zu erstellen und folgende Abfrage auszuführen:

    CREATE FULLTEXT INDEX entry_idx on serendipity_entries (title,body,extended)

    Die genaue Fehlermeldung der Datenbank bei der Suche lautete:

    SELECT
                                e.id,
                                e.authorid,
                                a.realname AS author,
                                e.allow_comments,
                                e.moderate_comments,
                                a.email,
                                e.timestamp,
                                e.comments,
                                e.title,
                                e.body,
                                e.extended,
                                e.trackbacks,
                                e.exflag,
                                e.isdraft,
                                e.last_modified,
                                a.username AS loginname
                       
                          FROM
                                serendipity_entries e
                     LEFT JOIN  serendipity_authors a
                            ON  e.authorid = a.authorid
                     LEFT JOIN  serendipity_entrycat ec
                            ON  e.id = ec.entryid
                                 LEFT OUTER JOIN serendipity_entryproperties ep_access
                                                  ON (e.id = ep_access.entryid AND ep_access.property = 'ep_access')
     LEFT JOIN serendipity_entryproperties ep_sticky
                                                ON (e.id = ep_sticky.entryid AND ep_sticky.property = 'ep_is_sticky')
                         WHERE
                                (MATCH(title,body,extended) AGAINST('hallo*' IN BOOLEAN MODE))
                                 AND isdraft = 'false'  AND timestamp <= 1251840000 AND  (ep_access.property IS NULL OR ep_access.value = 'member' OR ep_access.value = 'public' OR (ep_access.value = 'private' AND e.authorid = 1)) 
                        GROUP BY e.id
                       
                      ORDER BY  orderkey DESC, timestamp DESC
                         LIMIT 5

     / Unbekanntes Tabellenfeld 'orderkey' in order clause



Leider bin ich mySQL recht unbedarft. Kann ich irgend etwas tun oder muss mein Provider mir etwas freischalten oder?

Danke im voraus
Robert
PS: Suchfunktion unter http://robertlender.info/blog
Nur ein Blog ...auf robertlender.info - natürlich mit S9y betrieben

S9y InfoCamp - der (inoffizielle) S9y-Podcast

User avatar
garvinhicking
Core Developer
Posts: 30014
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Suche funktioniert nicht

Post by garvinhicking » Wed Sep 02, 2009 5:13 pm

Hi!

Ja, das ist leider ein bekannter Bug der 1.5 Beta; wenn du auf einen aktuellen nightly snapshot wechselst ist das behoben (der snapshot wird identisch mit der Beta2 oder auch der finalen Version sein, kann also gefahrlos benutzt werden wenn man vorher schon die 1.5 beta hatte)

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
robert
Regular
Posts: 1042
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Re: Suche funktioniert nicht

Post by robert » Wed Sep 02, 2009 7:12 pm

Hallo Garvin,
wenn es so einfach ist :)
Danke für die Info.
Liebe Grüße
Robert
Nur ein Blog ...auf robertlender.info - natürlich mit S9y betrieben

S9y InfoCamp - der (inoffizielle) S9y-Podcast

HadleyB
Regular
Posts: 766
Joined: Sun Feb 12, 2006 12:47 am

Re: Suche funktioniert nicht

Post by HadleyB » Sat Sep 05, 2009 9:42 pm

Funktionierte tadellos!

mfg
Hadley
mfg
Hadley

User avatar
robert
Regular
Posts: 1042
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Re: Suche funktioniert nicht

Post by robert » Sat Sep 05, 2009 9:46 pm

Seit ich auf die 1.5 Beta nightly umgestiegen bin funktioniert es bei mir auch perfekt :D

Post Reply