Aggregator

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
modules
Regular
Posts: 43
Joined: Tue Apr 12, 2005 9:51 am

Aggregator

Post by modules » Sat Jul 04, 2009 1:37 pm

Hallo,

ich möchte gerne eine alte Gregarius Installation durch s9y + das Aggregator Plugin ablösen.

Der Import per opml meiner Feedliste und den Kategorien lief super, der Import der einzelen Feeds lief ohne Probleme durch.

Leider brechen die Überschrift und Artikel ab, sobald ein Sonderzeichen auftaucht.
Bsp:
Überschrift: Das ZDF m
Artikel: Das ZDF m

In der Konfiugration habe ich mich für UTF-8 entschieden.

Auch würde ich gerne auf die eigentliche Quelle verlinken, habe dazu aber keine Option gefunden bzw. wird kein Link angeboten. Kann ich das irgendwo anpassen?

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Aggregator

Post by garvinhicking » Sat Jul 04, 2009 1:51 pm

Hi!

Welche PHP Version läuft bei Dir? In welchem Zeichensatz waren die RSS Feeds?

Auch würde ich gerne auf die eigentliche Quelle verlinken, habe dazu aber keine Option gefunden bzw. wird kein Link angeboten. Kann ich das irgendwo anpassen?


Ja, das musst du im template einbauen, läuft über entryproperties (also {$entry.properties.blabla}). Dazu müsste es eine README im aggregatorplugin geben.

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

modules
Regular
Posts: 43
Joined: Tue Apr 12, 2005 9:51 am

Re: Aggregator

Post by modules » Sat Jul 04, 2009 2:21 pm

garvinhicking wrote:Welche PHP Version läuft bei Dir? In welchem Zeichensatz waren die RSS Feeds?


Die Version ist 5.2.x, die Zeichensätze sind vermutlich unterschiedlich, da ca. 35 unterschiedliche Feeds, wie z.B.:

http://de.rian.ru/export/rss2/index.xml -> <?xml version="1.0" encoding="utf-8"?>
http://blog.fefe.de/rss.xml?html -> <?xml version="1.0" encoding="UTF-8"?>

Ja, das musst du im template einbauen, läuft über entryproperties (also {$entry.properties.blabla}). Dazu müsste es eine README im aggregatorplugin geben.


Eine Readme gibt es leider nicht. Scheint die datei entries.tpl.orig aus dem plugin Ordner zu sein?
Wird diese beim Import genutzt?

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Aggregator

Post by garvinhicking » Sat Jul 04, 2009 5:09 pm

Hi!

Und das umlautproblem taucht überall auf, oder nur bei einigen feeds? Wie ist deine URL? Welche optionen hast du im aggregator gesetzt, vor allem welche parser bibliothel nimmst du?

Eine Readme gibt es leider nicht. Scheint die datei entries.tpl.orig aus dem plugin Ordner zu sein?
Wird diese beim Import genutzt?


Hm, könnt schwören da gabs mal was. die themepatch.diff wäre das, was man auf sein template grob anwenden muss. das muss man manuell machen.

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

Post Reply