Page 1 of 1

bestimmte Kategorie verbieten

Posted: Wed Jan 28, 2009 10:41 am
by rowi
Moin,

ich hätte da gern ein Problem :-)

Bzw. ich habe bereits eines. Seit ein paar Tagen ruft ein Hansenet-User Abends eine meiner Kategorien fast im Sekundentakt ab. Da lasten allein die php-Prozesse den Server stark aus. Da ich mit den Kategorien sowieso mal aufräumen wollte habe ich das teilweise jetzt vorgezogen, die fragliche Kategorie existiert nicht mehr. S9y gibt nun aber keine 4xx Fehlermeldung aus, was ja normalerweise auch gut ist, aber in diesem Falle stört da die Abrufe zwar laut Useragent von einem Firefox kommt, das Verhalten aber auf ein Skript hindeutet. Es wird nur die Kategorieseite selbst abgerufen, kein Element der Seite. Sperre ich die IP in der htaccess hören die Zugriffe auf, es scheint da entsprechende Abbruchbedingungen zu geben. Die IP ändert sich aber täglich :-/

Langer Rede, kurzes Anliegen, ich möchte nun nur eine Kategorie mit einem 403 (deny) beantworten, ansonsten die s9y Mechanismen in der .htaccess in Funktion lassen. Bisher war ich damit nicht erfolgreich :-(

Die zu blockenden Requests:
85.177.ABC.XYZ – - [24/Jan/2009:20:37:45 +0100] “GET /categories/7-Gentoo HTTP/1.1” 200 24796 “-” “Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.0.5) Gecko/2008121921 Gentoo Firefox/3.0.5”


die Kategorie 7 existiert wie gesagt nicht mehr und kann komplett blockiert werden

Re: bestimmte Kategorie verbieten

Posted: Wed Jan 28, 2009 10:49 am
by garvinhicking
Hi!

Wie wär's wenn Du eine Datei namens "403.php" anlegst, die mit schönem Text gestaltest ("Ey Du Doofkopp, hör auf!") und dann in der .htaccess als erste RerwriteRule:

Code: Select all

RewriteRule ^/categories/7-Gentoo$ /403.php [L,QSA]


Grüße,
Garvin

Posted: Wed Jan 28, 2009 11:19 am
by rowi
guter Vorschlag, reicht ja völlig aus.
Hab die Zeile
RewriteRule ^/categories/7-Gentoo$ /hasinetterrorist.html [L,QSA]
(müsste nicht auch einfach ein [F] gehen?) eingefügt aber nun bin ich verwirrt. Im Browser sehe ich auch bei Umgehung des Cache das normale Bloglayout mit der Meldung "Keine Einträge vorhanden" die ich ja gerade vermeiden wollte, benutze ich wget bekomme ich einen 404.
URL zum testen: http://rowi.standardleitweg.de/categories/7-Gentoo

Posted: Wed Jan 28, 2009 12:24 pm
by garvinhicking
Hi!

Ich weiß nicht ob ein [F] dann auch die HTML-Seite ausgeben würde.

Ein 404 wird immer gesendet, auch wenn dann der Bloginhalt erscheint...

Wie sieht deine komplette .htaccess jetzt aus?

Ggf. mal ^categories/7-Gentoo$ probieren

Grüße,
Garvin

Posted: Wed Jan 28, 2009 12:38 pm
by rowi
ohne den / vor categories funktioniert es jetzt. Mit [F] wird der Inhalt der Datei nicht ausgegeben was reichen würde um meinen Fan abzuwehren. Ich denke aber ich werde in die Datei noch eine kurze Erklärung schreiben für Leute die sich einen Link direkt auf die Kategorie gespeichert hatten. Denke zwar nicht dass das der Fall ist aber es dürfte ja auch nicht schaden.
DANKE für die Hilfe!