seit update auf 1.4 kann ich keine Einträge mehr erstellen

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
Buggy
Regular
Posts: 29
Joined: Wed Sep 14, 2005 11:32 pm

seit update auf 1.4 kann ich keine Einträge mehr erstellen

Post by Buggy » Sat Jan 17, 2009 11:22 am

Habe meinen blog auf die 1.4 geupdatet. seitdem kann ich zwar meinen vorhandenen Datensatz sehen(ca 700 Einträge) aber wenn ich einen neuen erstelle und dann als veröffentlichen speichere zeigt er mir diesen dann nicht an. Auch nicht unter Einträge bearbeiten. Er ist so als hätte ich nie einen geschrieben. Speichere ich Ihn als Etwurf zeigt er ihn mir unter einträge bearbeiten.


was ist da falsch gelaufen.

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: seit update auf 1.4 kann ich keine Einträge mehr erstell

Post by garvinhicking » Sat Jan 17, 2009 12:34 pm

Hi!

Welche Ereignisplugins hast du installiert? Was siehst du auf dem Bildschirm,. wenn du einen Eintrag als Veröffentlichung speicherst?

wurde an deinem Server etwas geändert, z.b. eine Firewall aktiviert?

Testweise könntest du mal in deiner serendipity_config_local.inc.php eine Variable $serendipity['noautodiscovery'] = true; einfügen, damit werden Trackbacks deaktiviert die vielleicht verantwortlich sein könnten. Probier audch mal einen Eintrag zu veröffentlichen, der keinerlei Hyperlinks enthält.

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

Buggy
Regular
Posts: 29
Joined: Wed Sep 14, 2005 11:32 pm

Post by Buggy » Sat Jan 17, 2009 3:19 pm

Die Archive durchstöbern version: 1.0
Standard Serendipity Textformatierung durchführen version: 1.3
Konvertiert Zeilenumbrüche zu HTML version: 1.7
Wendet verschiedene (CSS) Methoden an, um maximale Browserkompatibilität zu erreichen version: 1.1
Spartacus version: 2.21
Erweiterte Optionen für Bildauswahl version: 0.18
Umfragen version: 2.04
Statische Seiten version: 3.43
Kontaktformular version: 1.12
WrapURL (pagetitle) version: 0.4
Blog als PDF exportieren version: 1.7
Textformatierung: Smilies version: 1.6
Nächster/Voriger Artikel version: 1.33
Lightbox/Thickbox JS/Graybox version: 1.3
Gästebuch version: 2.5
Sichert Einträge beim Schreiben automatisch im Hintergrund version: 0.2.2

Diese o.g. Ereignisplugins sind alle installiert.
Wenn ich einen Eintrag mache ist dies normal möglich. Habe als titel und eintrag lediglich das Wort Test ohne jegliche Hyperlinks verwendet. Beim speichern gibt er mir ober folgende Info(grün)
Serendipity speichert nun den Eintrag, erstellt etwaige Trackbacks und führt mögliche XML-RPC Aufrufe durch. Dies kann eine Weile dauern ...

Auch das ändern der serendipity_config_local.inc.php brachte keinen Erfolg

Verwende seit dem Update das Bulletproof Style. Wenn ich eine Such durchführe erhalte ich folgenden Fehler.

Suche
Die Suche konnte nicht wie gewünscht ausgeführt werden. Hinweis für den Administrator dieses Blogs: Dieser Fehler kann durch fehlende Index-Schlüssel der Datenbank verursacht werden. Auf MySQL-Systemen muss der Datenbankbenutzer-Account in der Lage sein, Index-Schlüssel zu erstellen und folgende Abfrage auszuführen:
CREATE FULLTEXT INDEX entry_idx on serendipity_entries (title,body,extended)Die genaue Fehlermeldung der Datenbank bei der Suche lautete:
SELECT
e.id,
e.authorid,
a.realname AS author,
e.allow_comments,
e.moderate_comments,
a.email,
e.timestamp,
e.comments,
e.title,
e.body,
e.extended,
e.trackbacks,
e.exflag,
e.isdraft,
e.last_modified,
a.username AS loginname

FROM
serendipity_entries e
LEFT JOIN serendipity_authors a
ON e.authorid = a.authorid
LEFT JOIN serendipity_entrycat ec
ON e.id = ec.entryid
LEFT JOIN serendipity_category c
ON ec.categoryid = c.categoryid LEFT JOIN serendipity_authorgroups AS acl_a
ON acl_a.authorid = 3
LEFT JOIN serendipity_access AS acl_acc
ON ( acl_acc.artifact_mode = 'read'
AND acl_acc.artifact_type = 'category'
AND acl_acc.artifact_id = c.categoryid
)
WHERE
(MATCH(title,body,extended) AGAINST('asdfsadf'))
AND isdraft = 'false' AND (
c.categoryid IS NULL
OR ( acl_acc.groupid = acl_a.groupid OR acl_acc.groupid = 0)
OR ( acl_acc.artifact_id IS NULL

)
)
GROUP BY e.id

ORDER BY timestamp DESC
LIMIT 10 / Can't find FULLTEXT index matching the column list
Keine Einträge vorhanden


Hat dieser Fehler auch etwas damit zu tun ?

Buggy
Regular
Posts: 29
Joined: Wed Sep 14, 2005 11:32 pm

Post by Buggy » Sun Jan 18, 2009 7:26 pm

Hm,
nun habe ich mal einige Versuche gestartet. Unter anderem auch ein altes Backup wieder drauf gespielt. Komischer weise konnte ich jetzt auch bei der 1.4 alpha ... keinen Eintrag mehr veröffentlichen. Durch zufall habe ich mal den browser gewechselt. Und siehe da mit dem Firefox 3.0.5 funzt alles. Mit dem IE 7.0.6001.18000 klappts nicht. Was ist denn das jetzt schon wieder.

Meinen Fehler mit der suchefunktion ein eintrag oberhalb
habe ich aber immer noch.

User avatar
robert
Regular
Posts: 1059
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Post by robert » Sun Jan 18, 2009 8:30 pm

Ich habe ein ähnliches Problem. Neue Einträge werden erstellt, aber nach der ersten Vorschau nicht weiter gespeichert (aber nur in Firefox und MacOS). In Safari funktioniert alles tadellos.
Hinzu kommt, dass bei einer Vorschau des Eintrags (bei Firefox) die Startseite der Verwaltungsoberfläche im Bereich der Vorschau angezeigt werden.
Nur ein Blog ...auf robertlender.info - natürlich mit S9y betrieben

S9y InfoCamp - der (inoffizielle) S9y-Podcast

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Post by garvinhicking » Mon Jan 19, 2009 11:44 am

Hi!

Habt ihr mal eure cookies gelöscht?

Grüße,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
robert
Regular
Posts: 1059
Joined: Mon May 09, 2005 9:17 pm
Location: Vienna, Austria
Contact:

Post by robert » Mon Jan 19, 2009 6:25 pm

Garvin,
ich zerknirsche mich vor dir :-)
Genau das war es!!!!

Ich sollte mir irgendwo einen großen Zettel aufhängen:

Bei Darstellungsproblemen zuerst IMMER:

* template_c leeren
* Cookies löschen

Danke dir für deine Hilfe.
Liebe Grüße
Robert
Nur ein Blog ...auf robertlender.info - natürlich mit S9y betrieben

S9y InfoCamp - der (inoffizielle) S9y-Podcast

Post Reply