Umlaute nicht richtig angezeigt

Hier können Probleme und alles andere in Deutscher Sprache gelöst werden.
Post Reply
blogsash
Regular
Posts: 17
Joined: Sun Mar 31, 2013 3:56 am
Location: Rostock
Contact:

Umlaute nicht richtig angezeigt

Post by blogsash » Tue May 07, 2013 7:02 pm

Hallo Community,

ich habe auf meinem Blog unter http://alexliebrecht.com ein Problem und zwar werden die Umlaute nicht korrekt angezeigt. Woran könnte es liegen? Danke euch für eure Antworten.

Mokkujin
Regular
Posts: 58
Joined: Thu Feb 11, 2010 12:59 pm
Location: Hannover, Germany
Contact:

Re: Umlaute nicht richtig angezeigt

Post by Mokkujin » Tue May 07, 2013 7:07 pm

Sieht für mich nach einem UTF-8 Problem aus.

Ist das ein root Server oder Webspace ?

blogsash
Regular
Posts: 17
Joined: Sun Mar 31, 2013 3:56 am
Location: Rostock
Contact:

Re: Umlaute nicht richtig angezeigt

Post by blogsash » Tue May 07, 2013 7:22 pm

Hallo,

ich habe einen eigenen Server bei All-inkl und darauf wird diese Domain gehostet.

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: Umlaute nicht richtig angezeigt

Post by Timbalu » Tue May 07, 2013 7:28 pm

möglicherweise sind die utf8-locales nicht generiert...
Was steht bei Konfiguration -> Generelle Einstellungen -> Zeichensatz-Auswahl ?
PHP 5.4 läuft mit utf8 als default. (was sagt dein php.ini?)
Vielleicht musst du auch diese etwas neuere MySQL Version an utf8 anpassen (my.ini)...
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

blogsash
Regular
Posts: 17
Joined: Sun Mar 31, 2013 3:56 am
Location: Rostock
Contact:

Re: Umlaute nicht richtig angezeigt

Post by blogsash » Tue May 07, 2013 7:37 pm

Unter Zeichensatz-Auswahl steht UTF-8.

Einen Zugriff auf php.ini habe ich bei All-inkl nicht. So steht in den Hinweise bei dem Webhoster.

Und wie gelange ich an my.ini? Habe gerade gegoogelt, finde aber nichts :-(.

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: Umlaute nicht richtig angezeigt

Post by Timbalu » Tue May 07, 2013 8:38 pm

huch - eigener Server und keinen Zugang? Vielleicht heißt die my.ini auch anders bei linux, das weiß ich gerad nicht auswendig....

Hast du PhpMyAdmin? Dann auf den Home Button klicken, müsste im Mainframe unter Datenbank Server soetwas stehen: Server Zeichensatz: UTF-8 Unicode (utf8)
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

blogsash
Regular
Posts: 17
Joined: Sun Mar 31, 2013 3:56 am
Location: Rostock
Contact:

Re: Umlaute nicht richtig angezeigt

Post by blogsash » Tue May 07, 2013 8:52 pm

Ja, leider kein Zugang oder ich bin schlecht informiert. Jedenfalls steht es so auf den Seiten von All-inkl.
So ich habe jetzt nachgeschaut in PHPmyAdmin, dort steht folgendes. Siehe Screenshot!

Image

blogsash
Regular
Posts: 17
Joined: Sun Mar 31, 2013 3:56 am
Location: Rostock
Contact:

Re: Umlaute nicht richtig angezeigt

Post by blogsash » Wed May 08, 2013 6:58 pm

Muss ich jetzt etwas umstellen?

blogsash
Regular
Posts: 17
Joined: Sun Mar 31, 2013 3:56 am
Location: Rostock
Contact:

Re: Umlaute nicht richtig angezeigt

Post by blogsash » Wed May 08, 2013 7:08 pm

Hallo Leute,

nun habe ich es geschafft. Ich habe in PHPmyAdmin auf UTF8 Unicode umgestellt und die Umlaute werden nun richtig angezeigt. Danke für eure Tipps!!

User avatar
bookhacker
Regular
Posts: 11
Joined: Tue Mar 06, 2018 12:53 am
Contact:

Re: Umlaute nicht richtig angezeigt

Post by bookhacker » Tue Mar 06, 2018 12:59 am

Hi Board,

hab da auch so ein seltsames Umlaute-Problem (alles Unwichtige unkenntlich gemacht):
screenshot.jpg
screenshot.jpg (72.52 KiB) Viewed 1025 times
Wie man sieht, werden Umlaute generell korrekt angezeigt, nur im Post-Date nicht.
  • Zeichensatz der MySQL-Datenbank ist "utf8mb4_unicode_ci".
  • Die Serendipty-"Wartung/Installation prüfen" spuckt folgende Meldung aus:
    "include/tpl/config_local.inc.php beschädigt oder verändert: Überprüfung fehlgeschlagen"
  • "Datenbank-Zeichensatzkonvertierung aktivieren" steht auf "Ja" (deaktiviere ich sie, erhalte ich überall Umlaute-Brei).
  • "Zeichensatz-Auswahl" steht auf "UTF-8".
  • PHP-Version ist 7.2. Die Version umzustellen führt zu keiner Änderung.
Muss ich irgendwelche Dateien patchen (include/tpl/config_local.inc.php), den Zeichensatz in der MySQL-Datenbank umstellen oder ist das so'n PHP-Locale-Problem, wegen dem ich mich an meinen Webspace-Anbieter wenden muss?

User avatar
garvinhicking
Core Developer
Posts: 30015
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Umlaute nicht richtig angezeigt

Post by garvinhicking » Mon Mar 12, 2018 1:35 pm

Hi!

Die Umlaute in Datumsangaben kommen vom System aus den Datums-Locales. Dafür nutzt serendipity standardmäßig das locale mit "_UTF-8" suffix. Dein System hat offenbar keine Locales für die Datumsangaben und müsste nachinstalliert werden. Bitte deinen Provider einmal, die UTF-8 Locales für de_DE nachzuinstallieren.

LG,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
bookhacker
Regular
Posts: 11
Joined: Tue Mar 06, 2018 12:53 am
Contact:

Re: Umlaute nicht richtig angezeigt

Post by bookhacker » Mon Mar 12, 2018 9:53 pm

garvinhicking wrote:Die Umlaute in Datumsangaben kommen vom System aus den Datums-Locales. Dafür nutzt serendipity standardmäßig das locale mit "_UTF-8" suffix. Dein System hat offenbar keine Locales für die Datumsangaben und müsste nachinstalliert werden. Bitte deinen Provider einmal, die UTF-8 Locales für de_DE nachzuinstallieren.
Danke für den Tipp, Garvin! Bin irgendwann nach dem Posten hier auf den entsprechenden FAQ-Eintrag zu dem Thema bei Serendipity Styx Edition gestoßen und danach auf den FAQ-Eintrag hier im Serendipity-FAQ. Klassischer Fall von RTFM (nur leider rankt der Forums-Eintrag in der Google-Suche höher als der FAQ-Eintrag).

Hab's mal an meinen Webhoster weitergegeben und warte auf Rückmeldung.

User avatar
bookhacker
Regular
Posts: 11
Joined: Tue Mar 06, 2018 12:53 am
Contact:

Re: Umlaute nicht richtig angezeigt

Post by bookhacker » Wed Mar 14, 2018 9:34 pm

Webhoster teilt mit, die Locales seien auf dem System vorhanden. Problem besteht weiterhin.

User avatar
erAck
Regular
Posts: 57
Joined: Mon Feb 16, 2015 2:20 am

Re: Umlaute nicht richtig angezeigt

Post by erAck » Thu Mar 15, 2018 2:49 am

bookhacker wrote:Webhoster teilt mit, die Locales seien auf dem System vorhanden.
Wenn du einen Shell-Zugang hast laesst sich das ueberpruefen:

Code: Select all

LC_TIME=de_DE.UTF-8 date --date=2018-03-15 +%B
sollte März ausgeben. (vorausgesetzt dein lokales Terminal macht UTF-8 )
Evtl. kann auch LC_ALL statt LC_TIME fuer den Test noetig sein falls LC_ALL bereits anders gesetzt ist.

User avatar
bookhacker
Regular
Posts: 11
Joined: Tue Mar 06, 2018 12:53 am
Contact:

Re: Umlaute nicht richtig angezeigt

Post by bookhacker » Thu Mar 15, 2018 9:21 pm

erAck wrote:Wenn du einen Shell-Zugang hast ...
Nope, leider kein Shell-Zugang.

Ich kann mir aber ehrlich gesagt nicht vorstellen, dass der Fehler irgendwo bei Serendipity liegt. Es sei denn, auf dem Server gibt es noch andere Einstellungen, die wichtig sind.

Könnten noch irgendwelche .php-Einstellungen per .htaccess notwendig sein?

Post Reply