Page 1 of 1

Captchas not visible ?!

Posted: Mon Apr 30, 2007 4:18 pm
by baden32
I'm using Serendipity 1.1 and I just activated the captchas in order to reduce spam.

Unfortunately, I cannot see any image when the html form is displayed.

In fact instead of the captcha, I can see a blanck rectangle but no caracters. Do I need to make a special setup here?

Thank you in advance for your help.

Posted: Mon Apr 30, 2007 8:23 pm
by d_cee

Unless you've got your captchas configured for all authors you won't see them if you're logged in.



Posted: Mon Apr 30, 2007 9:21 pm
by baden32
Hi Dave,
Thank you for your reply.
In fact :
1. Captchas are enabled for all users
2. I was displaying the page on another PC

Under the comment form, I can see the text saying that I need to type the text displayed in the Captcha in the text field. Unfortunately, I cannot see the image.

Thanky for your help.

Posted: Mon Apr 30, 2007 10:32 pm
by dom97
I thought captchas were only available for people/users who were not logged in.

So if your an admin logged in, you won't see them.

I could be wrong. I'll have to check.

Posted: Mon Apr 30, 2007 10:48 pm
by baden32
I Dom,
As mentionned in my previous message, I'm loggged in on a PC (where I do the administration) and I display the result on another PC where I'm NOT logged. So I expect to see the Captchas, am I wrong?

Posted: Mon Apr 30, 2007 10:50 pm
by judebert
Could be that you're configured for GD image processing, but GD is not installed. (Or the same for ImageMagick.) Could we see the URL in question? That way we can look at the source and get a better idea of what's going on.

Posted: Mon Jul 23, 2007 6:45 pm
by woocha
I am logged out and mY captcha only displays a red X what is going on?

Posted: Mon Jul 23, 2007 7:40 pm
by garvinhicking

Your URL rewriting seems to be broken somehow. If I call this URL: ... eea37b1f71

This should display a cpatcha, but instead it tries to 404 redirect to 'missing.html'.

Did you modify your .htaccess file somehow? Where does this 'missing.html' 404 come from? It's not from Serendipity. If you modify your .htaccess, you might need to turn URL Rewriting off in the serendipity configuration. Then the URL above would look like: ... eea37b1f71

Which properly displays the captcha.


Posted: Mon Jul 23, 2007 8:05 pm
by woocha
I never touched the .htaccess file.
So, basically so are saying that my browser is displaying a link to my captcha that is missing ' index.php? '. Do you know of anyway to add it in? I can't seem to find where to edit that link to captcha

Posted: Mon Jul 23, 2007 10:50 pm
by garvinhicking

What does your .htaccess file look like? Somewhere your server generates a redirect to "missing.html". Serendipity itself doesn't do this!

You can solve thisby entering your s9y configuration and setting the option "URL Rewriting" to "None". You'll then have links prefixed with "index.php?/".BUT then you won't have the "pretty URLs", which basically seem to work with your server, but because of a problem unknown to me, the captcha one is redirecting to missing.html. This might be due to the .htaccess or because of some provider-changes on your server.


Posted: Mon Jul 23, 2007 11:54 pm
by woocha
Hey garvin

thanks a lot. That did it. It works great now. :D
Sure enough, you were right, the .htaccess file got written to when I made the URL's pretty. I didn't even think about that. Thank you.
Do you know of anyway to increase the number of display characters in the Captcha?

Posted: Tue Jul 24, 2007 2:12 pm
by garvinhicking

There's no config option for increasing the characters in the captcha. But this shouldn't really be needed, it is hard to read enough already, right? :)


Posted: Tue Jul 24, 2007 6:31 pm
by woocha
yeah, your right. I just thought it would look nicer if the 3 chars could fill the entire background space.

thank you for checking though