Upgrade problem

Having trouble installing serendipity?
Post Reply
deedw
Regular
Posts: 53
Joined: Thu Oct 07, 2010 5:57 am

Upgrade problem

Post by deedw » Sun Aug 09, 2020 9:23 am

Hi,

I've upgrade from an older version 2.1.2 to 2.3.5. Now I have the following problems:

1. Login is not remembered. Even after two days I need to login again.
2. After login, saving a posting or doing some other actions it just shows an empty page. Reloading helps but sends the data a second time I think.
3. Last time changing and saving a posting leads to publishing the same posting two times. One with changes and one without.
4. Including pictures with caption is broken now. I see the "figure" and "figcaption" tag directly printed on the webpage. So as it does not know that it should be parsed as HTML.

Is any of this known?

Is there a manual how I can restart from scratch? I mean how to install a clean S9Y installation and then "importing" all necessary settings? (How I prefer installations because upgrades usually keep some old stuff and some things get broken everytime.)

Best regards
Dee

User avatar
onli
Regular
Posts: 2463
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Upgrade problem

Post by onli » Tue Aug 11, 2020 9:18 am

In reverse order:

4. For the figcaption, that's a known bug that will be fixed next version. To fix it now replace the plugins/serendipity_event_nl2br.php with the version from the current master, https://github.com/s9y/Serendipity/blob ... _nl2br.php .

3. A entry that was already in the database before?

2. There might be a PHP 500 error that is not shown. It would be in the apache error log.

1. For the login, I'd try to delete all cookies linked to the blog domain and then try again. We had some changes there, but this seemed and seems to work. If the cookie deletion does not help: Which browser are you using?

deedw wrote:
Sun Aug 09, 2020 9:23 am
Is there a manual how I can restart from scratch? I mean how to install a clean S9Y installation and then "importing" all necessary settings?
I'm not aware of one, sorry. Even the serendipity importer - besides being just too old to look trustworthy - specifically states to not be an alternative to the upgrade process and to only work for the same version.

deedw
Regular
Posts: 53
Joined: Thu Oct 07, 2010 5:57 am

Re: Upgrade problem

Post by deedw » Fri Aug 21, 2020 8:17 pm

Hi onli,

I forgot to activate the notification for this thread ...

4. Maybe I will wait till the fix ... Hm, depending on how I go on with S9Y.

3. Yes. In my opinion I saved and published it. I think without closing I edited it and saved again. And then a second entry has been published.

2. It happens as well after writing a/replying to comment. I don't think I have access to the logs. I will check.

1. Ok, I try it.

User avatar
onli
Regular
Posts: 2463
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Upgrade problem

Post by onli » Fri Aug 21, 2020 8:32 pm

Yes. In my opinion I saved and published it. I think without closing I edited it and saved again.
Okay. That would be exactly the error situation I've already seen. It happens when the javascript that sets the id after an entry is generated for the first time dies. That Javascript is pretty simple and has been stable for a while, for the moment I would assume that this is a symptom of a different error that blocked the javascript creation (or the PHP, but only after saving the entry).

I hope everything can be pinpointed to one error message in the logs.

deedw
Regular
Posts: 53
Joined: Thu Oct 07, 2010 5:57 am

Re: Upgrade problem

Post by deedw » Sat Oct 03, 2020 11:28 pm

So, I finally reinstalled my blog. Here's a short manual how I did it:
  • Backup sql database via phpmyadmin.
  • Backup old Serendipity version from your server.
  • Install local LAMP server on your desktop.
  • Install stored database locally.
  • Extract latest Serendipity version.
  • Copy "uploads" folder from old version to new version.
  • Copy serendipity_config_local.inc.php from old version to new version.
  • Open http://localhost/~YOURNAME/blog/ and start installation.
  • Reinstall all missing plugins and events.
  • Check if everything works.
  • Rename old blog folder on server.
  • Upload new version to server.
At least for me it worked that way and I think most problems are solved now.

User avatar
onli
Regular
Posts: 2463
Joined: Tue Sep 09, 2008 10:04 pm
Contact:

Re: Upgrade problem

Post by onli » Sat Oct 03, 2020 11:57 pm

It's a pity we could not figure out what was wrong, but I'm happy you solved this!

Post Reply