Page 1 of 1

Integrity test failure during auto update to 2.3.0

Posted: Tue Aug 13, 2019 12:39 am
by wesley
When updating from 2.1.5 to 2.3.0 via auto update, everything seems to go well until the following errors occur and the process stops:

Code: Select all

Updating failed, because the integrity-test for the following files failed:
* /Library/WebServer/Documents/blog/templates_c/serendipity-2.3.0/serendipity/templates/next/font/fontello.svg
* /Library/WebServer/Documents/blog/templates_c/serendipity-2.3.0/serendipity/templates/2k11/admin/font/fontello.svg
* /Library/WebServer/Documents/blog/templates_c/serendipity-2.3.0/serendipity/bundled-libs/zendframework/zend-db/phpcs.xml
* /Library/WebServer/Documents/blog/templates_c/serendipity-2.3.0/serendipity/bundled-libs/simplepie/simplepie.inc
* /Library/WebServer/Documents/blog/templates_c/serendipity-2.3.0/serendipity/bundled-libs/katzgrau/klogger/phpunit.xml
I went to the templates_c folder and deleted the serendipity-2.3.0 folder and the zip file to force re-download, but the same errors occur even after doing that.

I wonder what's causing this problem.

Re: Integrity test failure during auto update to 2.3.0

Posted: Tue Aug 13, 2019 8:24 pm
by thh
wesley wrote:
Tue Aug 13, 2019 12:39 am

Code: Select all

Updating failed, because the integrity-test for the following files failed:
* /Library/WebServer/Documents/blog/templates_c/serendipity-2.3.0/serendipity/templates/next/font/fontello.svg
* /Library/WebServer/Documents/blog/templates_c/serendipity-2.3.0/serendipity/templates/2k11/admin/font/fontello.svg
* /Library/WebServer/Documents/blog/templates_c/serendipity-2.3.0/serendipity/bundled-libs/zendframework/zend-db/phpcs.xml
* /Library/WebServer/Documents/blog/templates_c/serendipity-2.3.0/serendipity/bundled-libs/simplepie/simplepie.inc
* /Library/WebServer/Documents/blog/templates_c/serendipity-2.3.0/serendipity/bundled-libs/katzgrau/klogger/phpunit.xml
I had the same problem, but didn't investigate (but installed 2.3.0 manually).
wesley wrote:
Tue Aug 13, 2019 12:39 am
I wonder what's causing this problem.
Obviously, the checksums don't match - I'm not sure why that could be (and only when trying to update using auto-update, but not when uploading the files by hand).