Page 1 of 1

Missing details in entry editor after update from 1.7

Posted: Mon Apr 29, 2019 3:33 pm
by ComPod
I've just upgraded my s9y from 1.7.8 (yeah, I know. But it worked) and am now missing the Categories, Tags and entry metadata options. There are places where I suppose those should be seen but whatever populates those fields doesn't seem to work (as seen in the screenshot I'm attaching). At first I assumed it was because I was still set to PHP 5.6 but switching to 7.2 didn't change anything. I'm pretty sure it's not something my browser fails to do as I'm seeing the same behavior on Firefox and Safari.

Any advice where and what I could try?

TIA

Re: Missing details in entry editor after update from 1.7

Posted: Mon Apr 29, 2019 3:51 pm
by MarioH
Hi,

have you already updated all plugins to the latest version?

Can you provide a screenshot of your backend?

Regards
Mario

Re: Missing details in entry editor after update from 1.7

Posted: Mon Apr 29, 2019 4:04 pm
by ComPod
To the second question: What kind of screenshot would be needed for that? I'm ready and willing to provide what I can.

to the first question: I can't do that, because apparently open_basedir is preventing me from that. With errorlogging enabled I'm getting that one down there. Is there another way for me to update the plugins?

Warning: require_once(): open_basedir restriction in effect. File(/usr/local/php7.2/lib/php/PEAR/Exception.php) is not within the allowed path(s): (/home/sites/site255/:/home/sites/site255/tmp/:/home/sites/www.compyblog.de/:/home/sites/www.compy ... ssl/certs/) in /home/sites/site255/web/bundled-libs/HTTP/Request2/Exception.php on line 24

Warning: require_once(/usr/local/php7.2/lib/php/PEAR/Exception.php): failed to open stream: Operation not permitted in /home/sites/site255/web/bundled-libs/HTTP/Request2/Exception.php on line 24

Fatal error: require_once(): Failed opening required 'PEAR/Exception.php' (include_path='.:/usr/local/php7.2/lib/php:/home/sites/site255/web/bundled-libs/:/home/sites/site255/web/bundled-libs/Smarty/libs/:/home/sites/site255/web/:') in /home/sites/site255/web/bundled-libs/HTTP/Request2/Exception.php on line 24

Re: Missing details in entry editor after update from 1.7

Posted: Mon Apr 29, 2019 4:16 pm
by ComPod
And then I found the reason. I was looking through the active plugins and comparing what the update had already brought up to standard and thinking about what could interfere with entry editing. The one missing plugin was freetag (event and plugin) and I decided to copy those two from github directly. Now it looks like the entry editor is happy again.

Now, why does the lugin updater refuse to work on its own?

Re: Missing details in entry editor after update from 1.7

Posted: Mon Apr 29, 2019 4:45 pm
by erAck
My guess: the Spartacus plugin updater still used the netmirror.org source, which is down since ages (or at least was last year..); use s9y.org instead or github.com; under Admin -> Settings -> Plugins, Event plugins, locate serendipity_event_spartacus, go to its Configuration; for File/Mirror location (XML metadata) and File/Mirror location (files) each choose github.com (or s9y.org); Save. Save also in case the value was already preset to s9y.org or github.com so the (new) values are written to the configuration.

Re: Missing details in entry editor after update from 1.7

Posted: Mon Apr 29, 2019 4:50 pm
by ComPod
I tried enforcing the setting (github) but when I call the plugin Update I still get that:
Warning: require_once(): open_basedir restriction in effect. File(/usr/local/php7.2/lib/php/PEAR/Exception.php) is not within the allowed path(s): (/home/sites/site255/:/home/sites/site255/tmp/:/home/sites/www.compyblog.de/:/home/sites/www.compy ... ssl/certs/) in /home/sites/site255/web/bundled-libs/HTTP/Request2/Exception.php on line 24

Warning: require_once(/usr/local/php7.2/lib/php/PEAR/Exception.php): failed to open stream: Operation not permitted in /home/sites/site255/web/bundled-libs/HTTP/Request2/Exception.php on line 24

Fatal error: require_once(): Failed opening required 'PEAR/Exception.php' (include_path='.:/usr/local/php7.2/lib/php:/home/sites/site255/web/bundled-libs/:/home/sites/site255/web/bundled-libs/Smarty/libs/:/home/sites/site255/web/:') in /home/sites/site255/web/bundled-libs/HTTP/Request2/Exception.php on line 24

Re: Missing details in entry editor after update from 1.7

Posted: Mon Apr 29, 2019 5:16 pm
by ComPod
So, it seems my hoster is doing something unexpected. Apparently the line
require_once 'PEAR/Exception.php';
in HTTP/Request2/Exception.php from the bundled libs caused a bunch of my problems. I changed it to point to the bundled PEAR/Exception.php by absolute path and then the updater only complained about single plugins that I decided to update manually (which is why I had downloaded the additional plugins as one big file already). And now I'm hoping I've found everything weird after the update and switch of php versions because that should really be enough

Re: Missing details in entry editor after update from 1.7

Posted: Mon Apr 29, 2019 8:47 pm
by erAck
It might even be that PHP 7.2 is too new for the current s9y 2.1.4 version; if you can, try with PHP 7.1 instead, which at least here runs fine.

Anyhow, not being able to include a file within the PHP installation looks odd.
Maybe you should talk to your hoster.
Then again, it might be the order within include_path, where the .../web/bundled-libs/... directories are appended after /usr/local/php7.2/lib/php, so the bundled version is not looked up first (but maybe that is on purpose? I don't now, I don't develop this).

Re: Missing details in entry editor after update from 1.7

Posted: Mon Apr 29, 2019 8:50 pm
by ComPod
erAck wrote:
Mon Apr 29, 2019 8:47 pm
It might even be that PHP 7.2 is too new for the current s9y 2.1.4 version; if you can, try with PHP 7.1 instead, which at least here runs fine.
I tried that, but it saw the php7.2 files as well. For now it seems I have a working configuration and unless I stumble across things being weird I'm inclined to leave them that way

Re: Missing details in entry editor after update from 1.7

Posted: Tue Apr 30, 2019 6:07 pm
by erAck
ComPod wrote:
Mon Apr 29, 2019 8:50 pm
I tried that, but it saw the php7.2 files as well.
The setup of your PHP environment, specifically include_path, likely is broken. Using PHP 7.1 should not include anything of PHP 7.2

Re: Missing details in entry editor after update from 1.7

Posted: Thu Jun 06, 2019 12:27 pm
by superhai
Warning: require_once(/usr/local/php7.2/lib/php/PEAR/Exception.php): failed to open stream: Operation not permitted in /home/sites/site255/web/bundled-libs/HTTP/Request2/Exception.php on line 24
see this..