Page 1 of 1

Upgrade from 1.5.1 in 2019

Posted: Sat Mar 09, 2019 4:30 pm
by claude_m
Hello.

So I still have 1.5.1 because I was too lazy upgrading any of my blogs and I still have PHP 5.4.45 running on my old server. It's time for an upgrade and for that I move to a managed server.

On the new server I can use PHP 5.6, 7.0, 7.1, 7.2, and 7.3.

I could not find an easy way to upgrade my blogs. I'd have to set up a local LAMP with the exact same directories. I could use a VM for that as I use Windows. Then I can at least use the same config and don't have to change everything when I move the blog.

Can I upgrade from 1.5 to 2.1 directly? Or should I upgrade to 1.6, 1.7, and 2.0 first?

Which versions of PHP should I use? I'd like to use PHP 7.2 once I'm finished. Is there a list of supported PHP versions? What PHP versions did s9y 1.5 support? It's really old and I saw that it's still using mysql_* instead of mysqli_*, which wouldn't even work on a new system without all that old deprecated stuff.

Is there no way to export the data and reimport everything on a new server? This way I could just set up a new blog and import everything. Or are there any other options?

Claude

Re: Upgrade from 1.5.1 in 2019

Posted: Sun Mar 10, 2019 6:48 pm
by yellowled
claude_m wrote:
Sat Mar 09, 2019 4:30 pm
Can I upgrade from 1.5 to 2.1 directly? Or should I upgrade to 1.6, 1.7, and 2.0 first?
Theoretically, 1.5 → 2.1 should be possible. I say „theoretically“ because I have never done this myself, but have seen people report updates from even older versions to 2.1. But of course, that kind of a version jump always has risks. You'll want to make backups.
claude_m wrote:
Sat Mar 09, 2019 4:30 pm
Which versions of PHP should I use? I'd like to use PHP 7.2 once I'm finished.
I think 2.1 is not quite ready for 7.2, that will be addressed in an upcoming release (I can't give you an ETA, but soon-ish). For 2.1, PHP 7.1 works fine (and is recommended).
claude_m wrote:
Sat Mar 09, 2019 4:30 pm
Is there a list of supported PHP versions? What PHP versions did s9y 1.5 support?
I don't think we have a list since historically, s9y has always tried to support as many environments as possible/feasible. As far as I know, that will have to change with the upcoming release (which will require PHP >= 7.0, I think).
claude_m wrote:
Sat Mar 09, 2019 4:30 pm
Is there no way to export the data and reimport everything on a new server?
Well, of course you can make a full backup and move that to a new server. It should not be necessary since the update process should work, even from 1.5 → 2.1. And a server move requires some "manual work".

https://docs.s9y.org/docs/faq/index.htm ... er-or-path

YL

Re: Upgrade from 1.5.1 in 2019

Posted: Sun Mar 17, 2019 12:10 pm
by claude_m
So I'm now trying to migrate my blog. First I will just try to get it running with the same version.
Then I will try to upgrade. I still have to decide which version. 1.7 or 2.1?

What exactly was the reason to go from 1.x to 2.x? Are there things that won't work any more?

How do I know whether a plugins still works in s9x 2.1?
For example I'm using serendipity_event_contentrewrite.
It requires 1.6, but how could I know which of the newer versions work?

All plugins I use:
  • serendipity_event_nl2br
    serendipity_event_s9ymarkup
    serendipity_event_contentrewrite
    serendipity_event_spamblock
    serendipity_event_entryproperties
And I altered the theme. I use the properties of serendipity_event_entryproperties in my theme. I can rewrite all that if necessary, but if I have to use a new theme it would be a lot of work.

Re: Upgrade from 1.5.1 in 2019

Posted: Sun Mar 17, 2019 6:41 pm
by yellowled
claude_m wrote:
Sun Mar 17, 2019 12:10 pm
What exactly was the reason to go from 1.x to 2.x? Are there things that won't work any more?
Please see the release announcement in the s9y blog (and all the following ones, if you want to be up to date).

Please also note that this was posted four years ago. You always want to keep your s9y version up to date. I get that people are always afraid an update might break their installation (please make backups!), and you're wondering about a lot of things like "Will my plugins still work?“.

Fair enough, but as of now you are using a software that is more than nine years old. It most definitely has a lot of security issues.
claude_m wrote:
Sun Mar 17, 2019 12:10 pm
How do I know whether a plugins still works in s9x 2.1?
You can not know this. Quite frankly, we – the s9y development team – can't, either. There are a lot of plugins, some of them are not very commonly used, you could have some sort of "special" web hosting … we can not test for all of this.

Given that 2.1 is almost four years old already, I guess we would have noticed by now if any plugin did not work at all. In general, I can not remember a plugin just magically not working with a new release. (I have been using s9y for 13 years now.)
claude_m wrote:
Sun Mar 17, 2019 12:10 pm
And I altered the theme. I use the properties of serendipity_event_entryproperties in my theme. I can rewrite all that if necessary, but if I have to use a new theme it would be a lot of work.
You should not have to use a new theme. (Disclosure: I do not know what you altered, so I can't promise you your customized theme will work. It should.)

YL