Added Disqus, trying to disable "native" comments

Having trouble installing serendipity?
Post Reply
Cythraul
Posts: 1
Joined: Fri Oct 23, 2015 5:23 am

Added Disqus, trying to disable "native" comments

Post by Cythraul » Fri Oct 23, 2015 5:28 am

Hello, all!

I've just installed Serendipity 2.0.2, and enabled the serendipity_event_disqus plugin to allow Disqus commenting.

And that seems to work!

What doesn't seem to work is that I can't disable Serendipity's native commenting. Users who try to comment are presented with two comment forms - the Disqus one, and the native one - and they're able to use both.

Even the emergency comment disable option under Spam Controls doesn't prevent users from using the native commenting form.

Any suggestions?

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Added Disqus, trying to disable "native" comments

Post by garvinhicking » Mon Oct 26, 2015 12:56 pm

Hi!

The easiest way would be to insert some CSS to hide away the form:

Code: Select all

.serendipityCommentForm {
 display: none
}
A second way would be to create/fork your own template and edit the commentform.tpl file to remove the HTML markup for such a form...

HTH,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

Post Reply