Permissions

Having trouble installing serendipity?
Post Reply
grosmont
Regular
Posts: 7
Joined: Sun May 17, 2015 10:11 pm

Permissions

Post by grosmont » Mon May 18, 2015 4:35 pm

I have the latest version of serendipity installed. Everything works well apart from uploading media and changing the configuration. I get the following errors when trying to change the configuration.

-----
Forbidden

You don't have permission to access /s9y/serendipity_admin.php on this server.

Additionally a 404 Not Found Error was encountered while trying to use the ErrorDocument to handle the request.
-------

All the file permissions appear correct. I suspect I need some specific commands in the .htaccess file for serendipity to operate correctly but cannot find any detail in the installation guide or forums.

Appreciate any advice.

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: Permissions

Post by Timbalu » Mon May 18, 2015 4:52 pm

Its probably still a permission error, since you get "You don't have permission to access"...
Please double check the required permissions described en detail here: http://www.s9y.org/11.html#A15
Otherwise we would need some more infos, about the server, the provider, your url, etc.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

grosmont
Regular
Posts: 7
Joined: Sun May 17, 2015 10:11 pm

Re: Permissions

Post by grosmont » Mon May 18, 2015 6:53 pm

The permissions look correct with the installation instructions. I have tried changing the config file to 755 then tried changing the settings but I still get the same error message. All the s9y folders are set to 755.

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: Permissions

Post by Timbalu » Tue May 19, 2015 11:28 am

grosmont wrote:Everything works well apart from uploading media and changing the configuration.
Did you really give write access to the s9y/uploads dir and the roots s9y/serendipity_config_local.inc.php file?
Try with 0775 or even 0777. After you get access, you can secure this a little more again.
You might also check if your server maybe has mod_security set active.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

grosmont
Regular
Posts: 7
Joined: Sun May 17, 2015 10:11 pm

Re: Permissions

Post by grosmont » Tue May 19, 2015 8:48 pm

Thanks Ian

The mod_security has been reset and I can now change the configuration. I still have issues with the uploads however: I can upload but the media library reports no files despite them being visible via ftp etc.. Paths appear to be correct. I will play with the permissions to see if I can get this working.

grosmont
Regular
Posts: 7
Joined: Sun May 17, 2015 10:11 pm

Re: Permissions

Post by grosmont » Tue May 19, 2015 9:52 pm

This is all now working - more or less. There is still an issue adding media to an entry. I click on media from a new entry, click on the required image which opens a pop up on greyed background. I can add the various requirements for the image but when I click on DONE nothing happens. So the only way I have to add the image to an entry is using the image file location which is not ideal for some of the blog users. Appreciate any help. Thanks!

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: Permissions

Post by Timbalu » Wed May 20, 2015 11:32 am

I don't get what you mean with "via image file location"... being in the entry form.

About submitting the choosen media to the textarea with DONE and the empty result you get, this probably is a javascript error. Most current Browsers like Firefox or Chrome or IE have a Developer Tool Area on board, commonly opened by keyboard F12.
In the Console tab you can view problematic error messages or notices related to the current page. You may need to reload though.
Please share some light on what you might have there, which Browser and version you use, and if all page Browser restrictions (if have) have been reset, etc. Also could be interesting to know, which kind of requirements you selected to have this issue.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

grosmont
Regular
Posts: 7
Joined: Sun May 17, 2015 10:11 pm

Re: Permissions

Post by grosmont » Wed May 20, 2015 5:12 pm

Hi Ian

Using Opera 29.0 I get the following error message: -

Uncaught TypeError: Cannot set property 'opener' of undefined

Using Firefox 37.0.2: -

TypeError: parent.self is undefined

The problem appears to be that I am enclosing the Serendipity blog inside an <object> element within a page. Everything is fine when I access Serendipity on its own.

Is there any way around this? Or will I have to have the blog on its own?

Thanks

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: Permissions

Post by Timbalu » Wed May 20, 2015 5:27 pm

grosmont wrote:The problem appears to be that I am enclosing the Serendipity blog inside an <object> element within a page. Everything is fine when I access Serendipity on its own.
You are doing strange things! This is not what object is for: http://www.w3.org/TR/html401/struct/objects.html You probably mean <iframe> ...
grosmont wrote:Is there any way around this?
No! :) (Since parent.self is an JS inheritance from FRAME, not OBJECT! - https://developer.mozilla.org/en-US/docs/Web/Tutorials - Inline Frame Element (<iframe>) https://developer.mozilla.org/en-US/doc ... ent/iframe)
grosmont wrote: Or will I have to have the blog on its own?
Yes! Better!
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

Post Reply