Upgrade 1.5.2 to latest version

Having trouble installing serendipity?
hdiaz36
Regular
Posts: 57
Joined: Wed Feb 21, 2007 7:57 pm
Location: China (Yes, really)

Upgrade 1.5.2 to latest version

Post by hdiaz36 » Thu Feb 19, 2015 11:15 pm

I can't remember if I ever upgraded my blog, but really want to do that now.

I'm running 1.5.2 and just ran the "Verify Installation Integrity" and got the following errors:
include/genpage.inc.php corrupt or modified: failed verification
templates/carl_contest/entries.tpl corrupt or modified: failed verification
templates/carl_contest/style.css corrupt or modified: failed verification

I don't know why I tend to work on these things when severely sleep deprived, but always seems to be the case. I realized that I have no idea how to update my blog!

A few questions - which version should I upgrade to?
What is the easiest way to do this?

The main reasons I wish to upgrade are for security and also to explore newer plugins. Recently I was going to write a feature request here about multiple language entries or blogs but noticed an interesting plugin at the time. I tried installing the plugin on my test blog and the entire blog became inaccessible. Have no idea what went wrong there, but I don't want to suffer the same fate on my "live" blog, so decided first upgrading was the way to go.

Any guidance with this would be greatly appreciated.
Image

User avatar
yellowled
Regular
Posts: 7021
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Upgrade 1.5.2 to latest version

Post by yellowled » Fri Feb 20, 2015 12:08 am

hdiaz36 wrote:I'm running 1.5.2 and just ran the "Verify Installation Integrity" and got the following errors:
You're going to upload new versions of these with the update anyway, so they're probably not that much of a concern.
hdiaz36 wrote:A few questions - which version should I upgrade to?
We just released the shiny new 2.0, so we're encouraging people to use that. (BTW the download page always gives you a recommendation which version to use.) Unless you've read warnings about installing a specific version in the forums or the blog, you'll always want to be on the latest stable release.
hdiaz36 wrote:What is the easiest way to do this?
Pretty much the way it's outlined in the upgrade docs and FAQ, although that's kind of old (yet still accurate). It is also a bit more verbose than necessary.

(Also note that there is an Autoupdater plugin – serendipity_event_autoupdate – available on Spartacus which will give you the ability to update the blog from your backend, although I'm not sure how smoothly that will work in 1.5.2. Also might depend on your webspace setup.)

Some of this may also depend on your webspace setup, but basically you'll want to do this to do the upgrade “manually”:

- backup your s9y installation and database (just because 1.5.2 is pretty old; your hosting provider should have documentation on how to backup the database, the installation backup just means “copy all files in your webspace to your computer via (s)FTP or ssh)
- log out if you're logged into your blog
- download a copy of 2.0, unzip it and upload those unzipped files to your web space, overwriting the existing files, but not deleting any, especially not the .htaccess and serendipity_config_local.inc.php
- then just go to your blog's login (http://yourdomain.tld/serendipity_admin.php); you should be greeted by the upgrader which will lead you through the rest of the update process

That should be it. Sounds far more complicated than it is, but be aware that this might be more complicated in your case because frankly, 1.5.2 is pretty old. So wanting to update to a recent version (and keeping that updated regularly in the future) is more than just a good idea.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

User avatar
yellowled
Regular
Posts: 7021
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Upgrade 1.5.2 to latest version

Post by yellowled » Fri Feb 20, 2015 12:12 am

Oh, and if something should actually go wrong with the upgrade (here's hoping it goes smoothly):

– don't panic :wink:
– do not necessarily try to fix it yourself if you're not sure what to do
– report back to the forums with any error messages you might get

Apparently, some users think if an update goes wrong it's best to delete everything and start over, which is not necessarily the case.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

hdiaz36
Regular
Posts: 57
Joined: Wed Feb 21, 2007 7:57 pm
Location: China (Yes, really)

Re: Upgrade 1.5.2 to latest version

Post by hdiaz36 » Fri Feb 20, 2015 12:18 am

Thanks. I'll read through those links carefully and attempt the upgrade after I get some sleep.

Will report back here on the progress.
Image

hdiaz36
Regular
Posts: 57
Joined: Wed Feb 21, 2007 7:57 pm
Location: China (Yes, really)

Re: Upgrade 1.5.2 to latest version

Post by hdiaz36 » Fri Feb 20, 2015 11:38 am

Status report: Downloaded 2.0, uploaded and overwrote files on my server. Tried to access my blog's login, returned the following error message:

Serendipity requires a PHP version >= 5.3 - you are running a lower version (5.2.17) and need to upgrade your PHP version. Most providers offer you to switch to newer PHP versions through their admin panels or .htaccess directives.
Image

hdiaz36
Regular
Posts: 57
Joined: Wed Feb 21, 2007 7:57 pm
Location: China (Yes, really)

Re: Upgrade 1.5.2 to latest version

Post by hdiaz36 » Fri Feb 20, 2015 1:18 pm

After speaking with tech support at my webhost, they asked me the following questions:

In order for us to move you over to the correct server I'll need to know two things.

1. I seen you need `PHP` 5.3 but does it specify if you need a certain minor version? (5.3.27 or 5.3.28)

2. Do you know if you need a certain version of MySQL?

Any assistance with this would be greatly appreciated.
Thanks!
Image

User avatar
yellowled
Regular
Posts: 7021
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Upgrade 1.5.2 to latest version

Post by yellowled » Fri Feb 20, 2015 1:26 pm

hdiaz36 wrote:1. I seen you need `PHP` 5.3 but does it specify if you need a certain minor version? (5.3.27 or 5.3.28)
Wow, they are being overly specific. o_O

Technically, 2.0 only requires 5.3. It can be higher, though, especially given the fact that 5.3 has already reached it's end-of-life. Most providers offer a setting like 5.x which will always fall back to the latest patch version of that. For instance, I have my webspace set to 5.6, which currently falls back to 5.6.5 there.

Bottom line: It really depends on what they offer, but it needs to be at least 5.3. If they offer it, you should probably go with a recent 5.5.22 or 5.6.6, 5.4.38 would be the latest 5.4 version.
hdiaz36 wrote:2. Do you know if you need a certain version of MySQL?
Technically, you don't. But again, the webhoster should provide a recent MySQL version anyway.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

hdiaz36
Regular
Posts: 57
Joined: Wed Feb 21, 2007 7:57 pm
Location: China (Yes, really)

Re: Upgrade 1.5.2 to latest version

Post by hdiaz36 » Fri Feb 20, 2015 1:42 pm

Thanks!

Seems my blog is going to be unavailable for some time as I need to migrate to a new shared server since according to tech support PHP cannot be updated on the current shared server :(
Image

User avatar
yellowled
Regular
Posts: 7021
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Upgrade 1.5.2 to latest version

Post by yellowled » Fri Feb 20, 2015 1:57 pm

Sorry for not thinking about the new PHP requirement earlier. :( I'm not used to having to think about that since PHP >= 5.3 is pretty common on servers.
hdiaz36 wrote:Seems my blog is going to be unavailable for some time as I need to migrate to a new shared server since according to tech support PHP cannot be updated on the current shared server :(
Moving servers should not really take long, but of course, it depends on the hoster and how they work.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

hdiaz36
Regular
Posts: 57
Joined: Wed Feb 21, 2007 7:57 pm
Location: China (Yes, really)

Re: Upgrade 1.5.2 to latest version

Post by hdiaz36 » Fri Feb 20, 2015 2:22 pm

Haha, it's fine; better to deal with this right now when I have the time anyway.

Btw, I think the upgrade docs and FAQ need to be updated! 8)
Image

User avatar
yellowled
Regular
Posts: 7021
Joined: Fri Jan 13, 2006 12:46 pm
Location: Eutin, Germany
Contact:

Re: Upgrade 1.5.2 to latest version

Post by yellowled » Fri Feb 20, 2015 3:19 pm

hdiaz36 wrote:Btw, I think the upgrade docs and FAQ need to be updated! 8)
Why, did you run into specific problems with the articles I linked to?

Basically, everything that is docs on s9y.org could use an update. We would like to update the docs section with the contents of Garvins book in the future, but in order to do so, it would need to be translated from German to English first. Then, it would need a technical review and a mechanism to convert the original file format of the book to HTML, PDF, epub and mobi, including images and source code examples.

Bottom line: it is not an easy task. In general, keeping docs up to date is tedious and time-consuming. Given the fact that we only have a small dev team, we like to concentrate on developing the actual software as long as the existing documentation is not totally outdated.

YL
amazon Wishlist - Serendipity-Podcast (German only, sorry)

hdiaz36
Regular
Posts: 57
Joined: Wed Feb 21, 2007 7:57 pm
Location: China (Yes, really)

Re: Upgrade 1.5.2 to latest version

Post by hdiaz36 » Sat Feb 21, 2015 12:32 am

Ok, fair enough and quite understandable.

I didn't encounter a problem, per se, but I don't recall seeing anything about PHP 5.3 or higher being needed.

I totally agree though, since resources are limited it is best to focus on actual development. You guys have done an amazing job - keep up the great work!
Image

hdiaz36
Regular
Posts: 57
Joined: Wed Feb 21, 2007 7:57 pm
Location: China (Yes, really)

Re: Upgrade 1.5.2 to latest version

Post by hdiaz36 » Sat Feb 21, 2015 7:07 pm

Well, for the most part the upgrade seemed to go smoothly, however now there appear to be some Japanese kanji on the backend of my blog in the admin panel etc. My language is set to English, and mostly everything else appears in English, but a few buttons appears to be something other than English.

Help?
Attachments
japanese.jpg
japanese.jpg (19.06 KiB) Viewed 7934 times
Image

User avatar
Don Chambers
Regular
Posts: 3633
Joined: Mon Feb 13, 2006 3:40 am
Location: Chicago, IL, USA
Contact:

Re: Upgrade 1.5.2 to latest version

Post by Don Chambers » Sat Feb 21, 2015 9:51 pm

Those are supposed to be icons. Does this folder exist: /templates/2k11/admin/font/ ??

If so, does it contain the following files: fontello.wof, fontello.ttf, fontello.svg, fontello.eot ?

If no to either of these questions, upload the appropriate files.

hdiaz36
Regular
Posts: 57
Joined: Wed Feb 21, 2007 7:57 pm
Location: China (Yes, really)

Re: Upgrade 1.5.2 to latest version

Post by hdiaz36 » Sat Feb 21, 2015 10:39 pm

Yes, the folder exits, but one file has a slightly different name (I assume it's just a typo?)
I have fontello.woff, whereas you asked me to check for fontello.wof
Image

Post Reply