after install parse error

Having trouble installing serendipity?
jultey
Regular
Posts: 12
Joined: Sun Aug 30, 2015 12:48 am

Re: after install parse error

Post by jultey » Fri Sep 04, 2015 11:56 am

To avoid upgrading the installation, is there a way to export my articles, after to start from a fresh 2.0.2 installation and import my existing articles ?

I set a 777 permission on all files of my blog and I still have the same error.

I'm going to contact my host in order to have access to error.log file...

I am using this free host because it's the free space provided with my internet connection. It's one of the biggest host in France (called "Free Telecom"). I think they don't provide domain names. So I bought a domain (just redirection) + associate emails in another company.
I don't remember how the redirection is done (iframe or something like this) but whatever, what is important for me is the redirection works well and is cheap.

But, concerning my blog issue, I think it's not related to my domain name, because I didn't use it in the blog configuration. I only used the url provided by my free host.

I'll come back soon, when I'll have the log file in my possession.

Thanks Timbalu

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: after install parse error

Post by Timbalu » Fri Sep 04, 2015 12:18 pm

jultey wrote:is there a way to export my articles, after to start from a fresh 2.0.2 installation and import my existing articles ?
Yes. Via a mysql dump - but it depends a little how much it is and how much fragmented it is, how many plugins are used, etc. So this would need some handwork and knowledge.
jultey wrote:But, concerning my blog issue, I think it's not related to my domain name, because I didn't use it in the blog configuration.
I did not say that. I think so too. It is based to some misconfiguration or strange usage of that free host. Did you ask them already about these misinterpreted path settings, btw?
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

jultey
Regular
Posts: 12
Joined: Sun Aug 30, 2015 12:48 am

Re: after install parse error

Post by jultey » Thu Sep 10, 2015 10:37 pm

Hi Timbalu,
A 'long' time... but I have the solution. It was hard to contact my host, but with the help of newsgroups I find a solution (modulo anothe little bug ; cf. below).

I think the problem was I had 2 .htaccess files, 1 at the racine of my space, and 1 in the folder /blog. After removing the one in the /blog folder, and after using different contents of .htaccess, it finally works :)

Currently I have

Code: Select all

<IfDefine Free>
php56 1
</IfDefine>
The only remaining issue, is that some characters with accent are not displayed correctly : é, è, à...

I think I have to deal with somthing like

Code: Select all

AddCharset utf-8 .css .xml .po .php .js
with the good charset, but I didn't find yet which one is the good...

If I have time this week-end, I'll try several charset and post the good one in this thread.

Thanks again Timbalu

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: after install parse error

Post by Timbalu » Sun Sep 13, 2015 9:26 am

jultey wrote:I think the problem was I had 2 .htaccess files, 1 at the racine of my space, and 1 in the folder /blog. After removing the one in the /blog folder, and after using different contents of .htaccess, it finally works :)
You should not do this. To have Serendipity work right under certain conditions, you will have to keep the htaccess, but make it work together smoothly with a top level dir htaccess file rule. I don't think the "ifDefine Free php56" one should matter or interfere with Serendipity rules.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: after install parse error

Post by Timbalu » Mon Sep 14, 2015 10:05 am

For the charset problem you have to change the iframe page

Code: Select all

<meta http-equiv="content-type" content="text/html;charset=iso-8859-1">
to

Code: Select all

<meta http-equiv="content-type" content="text/html;charset=UTF-8">
since your Serendipty delivers and is set to UTF8 already.
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

jultey
Regular
Posts: 12
Joined: Sun Aug 30, 2015 12:48 am

Re: after install parse error

Post by jultey » Sun Sep 20, 2015 11:43 am

Hi Timbalu,

You mean I have to keep the .htaccess at the root of my space + add a .htaccess in the Serendipity main folder (in order to manage security only for the blog) ?
If yes, I am not very confortable with .htaccess. Maybe, you have an example of a .htaccess content (well setup for Serendipity) for serendipity you can share ? :)

For the é, à and other accents, I have not found where the meta content-type is set (in which file). So I have updated all my posts in order to replace strange characters by é, à, è, etc...

Thanks Timbalu for all your help on my blog !

User avatar
Timbalu
Regular
Posts: 4598
Joined: Sun May 02, 2004 3:04 pm

Re: after install parse error

Post by Timbalu » Sun Sep 20, 2015 12:06 pm

Keep the .htaccess in your web root.
If its only content is

Code: Select all

<IfDefine Free>
php56 1
</IfDefine>
that should do no harm to your blogs /blog/.htaccess file, which is set automatically by Serendipity, depending on your Servers environment CGI- or MODuled, having support for mod_rewrite or not (which is for nice urls) and depending of the configuration option you have set to "URL Rewriting" in "Appearance and Options". If you save the configuration form, the htaccess is automatically set or rewritten.

The Framed file should be in your domain environment, possibly called index.html and looks like:

Code: Select all

<html>
<head>
<title>Jultey : Julien Teyssier - Consultant PeopleSoft</title>
<!--12:01 PM-->
<meta http-equiv="content-type" content="text/html;charset=iso-8859-1">
<meta name="description" content="Julien Teyssier, consultant technico-fonctionnel PeopleSoft. Collaborateur de la soci&amp;amp;amp;#233;t&amp;amp;amp;#233; Starlog Conseil, SLCPI.">
<meta name="keywords" content="jultey, src, ntic, linux, informatique, corse, corte, informatique, julien, teyssier, cv, istm, essie management, consultant, peoplesoft, technique, erp, oracle, crm, peoplecode, starlog, slcpi">
<link rel="shortcut icon" href="http://jultey.free.fr/favicon.ico">
</head>
<frameset rows="*" border="0" framespacing="0" frameborder="0">
<frame src="http://jultey.free.fr/blog/" name="body" frameborder="0" noresize />
</frameset>
</html>
Here you needed to change the meta to UTF-8.
All other template files in Serendipity should already do that automatically, since getting the right var assigned: eg.

Code: Select all

<meta http-equiv="Content-Type" content="text/html; charset={$head_charset}" />
PS.: and "...de la société Starlog..." should be ..."de la soci&#233;t&#233; Starlog..." since that "&" was falsely multi encoded in the meta description field. :)
Regards,
Ian

Serendipity Styx Edition and additional_plugins @ https://ophian.github.io/ @ https://github.com/ophian

jultey
Regular
Posts: 12
Joined: Sun Aug 30, 2015 12:48 am

Re: after install parse error

Post by jultey » Fri Oct 02, 2015 4:56 pm

Thanks for all your help :) I think for now my blog is uptodate. Waiting with anxiety the next Serendipity version :)
Bye.
Julien

Post Reply