login reappeares when navigate tru menu

Having trouble installing serendipity?
User avatar
Rodnox
Regular
Posts: 75
Joined: Thu Jan 18, 2007 2:09 am
Location: Ennis Co. Clare, Ireland
Contact:

login reappeares when navigate tru menu

Post by Rodnox » Wed Jun 17, 2009 10:04 am

Now,

I've just come across a pretty wired problem.
When I log into my s9y blog, using adminuser (Userlevel 255) and password, I can log in as usual and see the Menu, etc.

But as soon as I choose a Link (no matter if that would be "New Entry", "Manage Styles" or anything else) I'm redirected to the Login window again.

And that happens over and over again. I've even changed my admin password in the database, to give it a try. But no change.

Maybe the URL can say something about that. After the redirection to Login window it looks like that:
http://www.website.com/blog/serendipity ... erendipity[adminModule]=entries&serendipity[adminAction]=new

But it still shows the login window.

Any ideas?

PS.: The Blog worked fine (appart from the Theme change thing) until yesterday. I just got a Comment, that was caught in the spamfilter and was marked as "Needs to be approved".

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: login reappeares when navigate tru menu

Post by garvinhicking » Wed Jun 17, 2009 10:33 am

Hi!

You upgraded your PHP, right? Did you make sure your php.ini settings for session storage are proper? The thing you are experiencing happens when PHP cannot keep the session data/session cookie.

Check your phpinfo() output for the session.* variables and see to that session.save_path is set to a writable path, that session.use_cookies is enabled. Basically, that this matches your prior settings, when it all worked.

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
Rodnox
Regular
Posts: 75
Joined: Thu Jan 18, 2007 2:09 am
Location: Ennis Co. Clare, Ireland
Contact:

Re: login reappeares when navigate tru menu

Post by Rodnox » Wed Jun 17, 2009 11:34 am

yeah, seems all cool

cookies are endabled in the php session and the save_path is html/username/phptmp

looks fine to me.

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: login reappeares when navigate tru menu

Post by garvinhicking » Wed Jun 17, 2009 11:37 am

Hi!

Hm, but something must have changed there. When s9y behaves like that, the session data cannot be associated across a HTTP request.

Check if html/username/phptmp contains data for the session ID that you get (you can inpsect the HTTP headers with firebug/livehttpheaders for example).

Maybe deleting all cookies related to your site in your browser and restarting the browser can also help.

But really, if PHP is the only thing you changed since when it last worked, the change must be with the PHP settings.

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
Rodnox
Regular
Posts: 75
Joined: Thu Jan 18, 2007 2:09 am
Location: Ennis Co. Clare, Ireland
Contact:

Re: login reappeares when navigate tru menu

Post by Rodnox » Wed Jun 17, 2009 12:43 pm

Okay, solved.

No idea what the problem was, but it works fine now.

I did nothing. Maybe the change of PHP Version took some time to find its way tru serendipity?

User avatar
judebert
Regular
Posts: 2478
Joined: Sat Oct 15, 2005 6:57 am
Location: Orlando, FL
Contact:

Re: login reappeares when navigate tru menu

Post by judebert » Thu Jun 18, 2009 4:18 pm

More likely it took some time running through your hosting provider. I've had this same problem before with my provider: sessions stop working even though I've done nothing. I open a trouble ticket, wait for a while, and it fixes itself. The provider always claims to have made no changes before or after, but I know for a fact I've made no changes.
Judebert
---
Website | Wishlist | PayPal

User avatar
Rodnox
Regular
Posts: 75
Joined: Thu Jan 18, 2007 2:09 am
Location: Ennis Co. Clare, Ireland
Contact:

Re: login reappeares when navigate tru menu

Post by Rodnox » Sun Jun 21, 2009 12:22 am

Now the blog is back to it's old tricks. No login possible.

I've made a video capture from the problem. Maybe that gives u an idea.

http://www.youtube.com/watch?v=L1Yx7fOrq6E

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: login reappeares when navigate tru menu

Post by garvinhicking » Sun Jun 21, 2009 1:51 am

Hi!

Ask your porivder if the session.save_path is maybe on a NFS or shared drive, and misbehaving? Also check the browser cookies like I mentioned.

The thing you show is typical for when no session cookie was created or no session data could be saved on the server.

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
Rodnox
Regular
Posts: 75
Joined: Thu Jan 18, 2007 2:09 am
Location: Ennis Co. Clare, Ireland
Contact:

Re: login reappeares when navigate tru menu

Post by Rodnox » Sun Jun 21, 2009 2:36 am

Since the theme problem is solved, the login works as well. thanks

mr_embo
Posts: 1
Joined: Sun Aug 09, 2009 6:27 pm

Re: login reappeares when navigate tru menu

Post by mr_embo » Sun Aug 09, 2009 6:32 pm

Hallo Rodnox, I had the same problem, now and then. After a while, I could figure out that when loging in, when appying a masked url address, the login went well, but as soon as I selected a admin-menu item, the login window re-appeared. Now, I have switched off URL masking, and the problem is solved.

hyejohn
Regular
Posts: 37
Joined: Mon Jun 22, 2009 4:04 pm
Location: Michigan, USA
Contact:

Re: login reappeares when navigate tru menu

Post by hyejohn » Sun Aug 09, 2009 7:12 pm

I've had this issue when logged into 2 blogs at the same time (using the same id and password.)
~John
That Photographer guy in Michigan

Raytravis
Posts: 3
Joined: Mon Aug 24, 2009 8:26 am

Re: login reappeares when navigate tru menu

Post by Raytravis » Tue Aug 25, 2009 8:50 am

Hi there,
Sorry to invade the thread.

I m facing the same problems tooo... And furthermore, my web layout when accessing the backend is just plain weird. No images or whatsoever. Lots of blank whitespaces. Can log in. Then when i clicked on other links, it redirects to the log in page again.

What is wrong with this? Please help me!

Raytravis
Posts: 3
Joined: Mon Aug 24, 2009 8:26 am

Re: login reappeares when navigate tru menu

Post by Raytravis » Tue Aug 25, 2009 9:03 am

And also, on the front end page, when i click on any link.
It said that, the pages cant be found.. =.=''

Will somebody help me please.... please.e....

hyejohn
Regular
Posts: 37
Joined: Mon Jun 22, 2009 4:04 pm
Location: Michigan, USA
Contact:

Re: login reappeares when navigate tru menu

Post by hyejohn » Tue Aug 25, 2009 2:34 pm

Raytravis wrote:And also, on the front end page, when i click on any link.
It said that, the pages cant be found.. =.=''

Will somebody help me please.... please.e....


Just a guess, but this is probably related to the other issue you posted... :shock:
~John
That Photographer guy in Michigan

User avatar
garvinhicking
Core Developer
Posts: 30020
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: login reappeares when navigate tru menu

Post by garvinhicking » Tue Aug 25, 2009 4:22 pm

Hi Ray!

When did you start getting these errors? Did you upgrade anything, changed path locations? Ask your provider if he changed anything.

Usually this only happens when the paths entered in the s9y configuration do not match, or your PHP Session storage is invalid.

Do you have access to phpMyAdmin? That could help to reset paths. But the most important thing would be to find out what happened since you last logged in properly.

Also, invalid links or 404 errors suggest that your hoster no longer offers you to use URL-Rewriting, or that your .htaccess file has been modified...

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

Post Reply