Page 1 of 1

Upgrade from 0.8 to 1.1.3

Posted: Wed Jul 18, 2007 2:45 am
by mojito
I had the following unsolved adventure while trying to upgrade from 0.8 to 1.1.3

I didnt understand where or how to run the upgrade ? so I did the following

I manually copied the contents of my old db to the new so that the new had the entries, everthing seems to work except for the images which give me the following error. Im also scared there may be other things later, so should I go back and do something differently. I didnt realise the database had changed so much..
here is the error related to the media

Code: Select all

SELECT  i.id, '' AS orderkey, i.name, i.extension, i.mime, i.size, i.dimensions_width, i.dimensions_height, i.date, i.thumbnail_name, i.authorid, i.path, i.hotlink, i.realname,
                     a.realname AS authorname
                     FROM serendipity_images AS i
       LEFT OUTER JOIN serendipity_authors AS a
                    ON i.authorid = a.authorid
                        LEFT JOIN serendipity_authorgroups AS acl_a
                                   ON acl_a.authorid = 1
                            LEFT JOIN serendipity_access AS acl_acc
                                   ON (    acl_acc.artifact_mode = 'read'
                                       AND acl_acc.artifact_type = 'directory'
                                       AND acl_acc.artifact_index = i.path
                                      )

                       WHERE 1=1  AND     (
                                 i.path IS NULL OR
                                        acl_acc.groupid IS NULL
                                 OR ( acl_acc.groupid = acl_a.groupid OR acl_acc.groupid = 0)
                                 OR ( acl_acc.artifact_id IS NULL
                                     
                                    )
                               )
                     GROUP BY i.id
            ORDER BY i.date DESC  LIMIT 0, 8

/ Unknown column 'i.realname' in 'field list'

I went back and found why it didnt go as the instructions..

Posted: Wed Jul 18, 2007 3:06 am
by mojito
I went back and found why it didnt go as the instructions said it would.

Im working on localhost to test the upgrade and have my install in reality still intact ! thank god here www.calvincrane.com

So I downloaded the latest stable version 1.1.3 and overwrote my localhost version 0.8

but upon hitting the install it gave me forbidden access, so I had to remove the .htaccess file to get it to allow entry, and no upgrade happened just got errors and thats why then I had to do things manually.

Im sure I need to get it working with this upgrade thing which should happen automatically, why doesnt it ?

thanks for any help, this is proving difficult.

Re: I went back and found why it didnt go as the instruction

Posted: Wed Jul 18, 2007 11:01 am
by garvinhicking
Hi!

Usuually you just upload the new versions OVER an existing installation. The file 'Serendipity_config_local.inc.php' needs to stay INTACT frmo the old version, otherwise serendipity will not UPGRADE itself.

When you see the INSTALL screen, you have done something wrong, you should never see that.

Have you checked the instructions in the FAQ on www.s9y.org?

Regards,
Garvin

Posted: Wed Jul 18, 2007 12:48 pm
by mojito
I did overwite the old with the new replacing files, not even an install screen, it just tried to start to work, and why would it kick into upgrade mode ?

I downloaded the zip version, the full version, there is not a specific upgrade zip no ?

Its sounds odd as there is no Serendipity_config_local.inc.php in the new version which i used to overwrite.

Since..

If I delete the .htaccess file and modify the version line to represent the old version then I got the upgrade screen and followed all the way through. It started to work but there was no style information telling me that it looked like a path was wrong, then i modifyed something and I just get stuck on a blank misconfiguration screen all the time now..

Is it possible to see some error messages to debug somehow rather than this unhelpful screen?

Posted: Wed Jul 18, 2007 1:56 pm
by garvinhicking
Hi!

mojito wrote:I did overwite the old with the new replacing files, not even an install screen, it just tried to start to work, and why would it kick into upgrade mode ?


What do you mean, it "just tried to star to work"? When you opened your blog, after uploading the files, what did you see? Only this error message from above?

The full version ZIP was the right one, yes.

Its sounds odd as there is no Serendipity_config_local.inc.php in the new version which i used to overwrite.


This file is only created on your server, it does not come with a serendipity version. So your file should not be missing unless you deleted it manually!

If I delete the .htaccess file and modify the version line to represent the old version then I got the upgrade screen and followed all the way through. It started to work but there was no style information telling me that it looked like a path was wrong, then i modifyed something and I just get stuck on a blank misconfiguration screen all the time now..


Can you provide a screenshot or your URL? I don'T understand what you mean with "no style information" and "blank misconfiguration screen"?

If you deleted the .htaccess file, you should go to serendipity_admin.php, configuration screen and then choose the option "URL Rewriting" to "none". Because .htaccess file is required if you chose a different URL Rewriting method, and that might be a reason you are seeing a strange layout...

Regards,
Garvin

Posted: Wed Jul 18, 2007 3:11 pm
by mojito
I finally got the upgrade thing to work, by temporary removing the htaccess file and changing the line

$serendipity['versionInstalled'] = '1.1.3';

to reflect my current version, I dont know why but this was not unzipped properly the first time round so it didnt overwrite, thanks for your help earlier friend.