[Solved] Fresh Install of 2.1.1 showing error 500

Having trouble installing serendipity?
Post Reply
gavinhenry
Regular
Posts: 5
Joined: Sat Sep 09, 2017 1:44 pm

[Solved] Fresh Install of 2.1.1 showing error 500

Post by gavinhenry » Mon Mar 05, 2018 1:37 am

Even though utf8_decode is in php-xml my fedora uses php-fpm, so restarting apache never actually loaded xml.so.

How annoying. If you hit this,

Code: Select all

systemctl restart php-fpm
Attachments
Screenshot from 2018-03-04 23-34-50.png
Screenshot from 2018-03-04 23-34-50.png (157.87 KiB) Viewed 307 times
Last edited by gavinhenry on Mon Mar 05, 2018 2:06 am, edited 1 time in total.

gavinhenry
Regular
Posts: 5
Joined: Sat Sep 09, 2017 1:44 pm

Re: Fresh Install of 2.1.1 showing error 500

Post by gavinhenry » Mon Mar 05, 2018 1:41 am

Adding this to index.php

Code: Select all

error_reporting(-1); // reports all errors
ini_set("display_errors", "1"); // shows all errors
ini_set("log_errors", 1);
ini_set("error_log", "/tmp/php-error.log");
gives:

Code: Select all

Fatal error: Uncaught Error: Call to undefined function utf8_decode() in /var/www/ghenry/include/functions_permalinks.inc.php:127 Stack trace: #0 /var/www/ghenry/include/functions_permalinks.inc.php(526): serendipity_makeFilename('OpenLDAP as a P...') #1 /var/www/ghenry/include/functions_permalinks.inc.php(625): serendipity_makePermalink('archives/%id%-%...', Array) #2 /var/www/ghenry/include/functions_entries.inc.php(1168): serendipity_archiveURL('1', 'OpenLDAP as a P...', 'serendipityHTTP...', true, Array) #3 /var/www/ghenry/include/genpage.inc.php(129): serendipity_printEntries(Array) #4 /var/www/ghenry/include/functions_routing.inc.php(18): include('/var/www/ghenry...') #5 /var/www/ghenry/index.php(108): serveIndex() #6 {main} thrown in /var/www/ghenry/include/functions_permalinks.inc.php on line 127

gavinhenry
Regular
Posts: 5
Joined: Sat Sep 09, 2017 1:44 pm

Re: Fresh Install of 2.1.1 showing error 500

Post by gavinhenry » Mon Mar 05, 2018 1:45 am

I do have php-xml installed on Fedora 27 64bit though. php 7.1.14

User avatar
garvinhicking
Core Developer
Posts: 30014
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany
Contact:

Re: Fresh Install of 2.1.1 showing error 500

Post by garvinhicking » Mon Mar 12, 2018 1:45 pm

gavinhenry wrote:I do have php-xml installed on Fedora 27 64bit though. php 7.1.14
Hm, does it work in a test script with the PHP CLI? Create a "info.php" in your s9y webspace, use "<?php phpinfo(); ?>" as content and call it in your browser and check if the xml library really shows up?!

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

gavinhenry
Regular
Posts: 5
Joined: Sat Sep 09, 2017 1:44 pm

Re: Fresh Install of 2.1.1 showing error 500

Post by gavinhenry » Mon Mar 12, 2018 1:50 pm

garvinhicking wrote:
gavinhenry wrote:I do have php-xml installed on Fedora 27 64bit though. php 7.1.14
Hm, does it work in a test script with the PHP CLI? Create a "info.php" in your s9y webspace, use "<?php phpinfo(); ?>" as content and call it in your browser and check if the xml library really shows up?!

Regards,
Garvin
I didn't restart php fpm so it only worked after that. My bad. Thanks though!

Post Reply