Search found 5 matches

by baxterdmutt
Sat Aug 25, 2018 6:10 pm
Forum: Bugs
Topic: Clean blog Warning: Parameter 2 to timeAgoInWords() expected to be a reference
Replies: 13
Views: 583

Re: Clean blog Warning: Parameter 2 to timeAgoInWords() expected to be a reference

But that's not the issue here. It's the place where references are allowed: A function definition. The issue is that it is not being given a reference, but a value. By the way, that collides with wthat the documentation is claiming, that PHP would handle that automatically by just declaring the ref...
by baxterdmutt
Sat Aug 25, 2018 6:59 am
Forum: Bugs
Topic: Clean blog Warning: Parameter 2 to timeAgoInWords() expected to be a reference
Replies: 13
Views: 583

Re: Clean blog Warning: Parameter 2 to timeAgoInWords() expected to be a reference

If this helps - from the php manual: “There is no reference sign on a function call - only on function definitions. Function definitions alone are enough to correctly pass the argument by reference. As of PHP 5.3.0, you will get a warning saying that "call-time pass-by-reference" is deprecated when ...
by baxterdmutt
Sat Aug 25, 2018 2:38 am
Forum: Bugs
Topic: Clean blog Warning: Parameter 2 to timeAgoInWords() expected to be a reference
Replies: 13
Views: 583

Clean blog Warning: Parameter 2 to timeAgoInWords() expected to be a reference

PHP is : 5.6.36-0+deb8u1 Serendipity Version 2.2.0-beta2 I've found a bug in the Clean-Blog template. When I click on 'preview' to preview a blog or comments I get this error: Fatal error: Uncaught exception 'ErrorException' with message 'Warning: Parameter 2 to timeAgoInWords() expected to be a ref...
by baxterdmutt
Wed Aug 22, 2018 2:30 am
Forum: Installation
Topic: theme server is not working
Replies: 7
Views: 2386

Re: theme server is not working

Well I feel dumb! the problem was open_base restrictions in a apache.conf file. All is well. Thanks. I thought I should mention it to anyone else that might come across the same issue.
by baxterdmutt
Wed Aug 22, 2018 12:14 am
Forum: Installation
Topic: theme server is not working
Replies: 7
Views: 2386

Re: theme server is not working

Hi, I just installed s9y and everything is working as it should except for the themes server and maintenance. I can't find anything anywhere that suggests what I've done wrong. I tried the different servers and I get the same with everything - a blank page. I checked the error logs and they just say...