The Serendipity Handbook

You can now read the (german) handbook here: PDF - https://github.com/s9y/Book (LaTeX source).

Forum-Information

Before posting about errors, make sure that the answer cannot already be found in our FAQ or by searching this forum!
Posting is restricted to registered users (registering is free and simple!) due to recent spam attacks. When having trouble with this board, contact garvin(-at)s9y(-dot)org.

Board index Plugins twitterOAuth.php causes parse error

Creating and modifying plugins.
ricardob
 
Posts: 2
Joined: Sun Jun 26, 2011 1:01 am

Postby ricardob » Sun Jun 26, 2011 1:23 am

Hello,

does anybody have an idea why the recent installation (1.37) of the Microblogging gets stuck when I try to sign in to twitter? The exact message in the popup window is

Parse error: syntax error, unexpected T_VARIABLE in /homepages/27/(..)/htdocs/(..)/plugins/serendipity_plugin_twitter/twitteroauth/twitteroauth.php on line 17

With my humble PHP knowledge I would say that there is syntax error in that file, I assume that there is a problem with my webspace provider's settings for the webserver (1&1).

Must be something very special because there doens seem to be anybody else than me who experienced this...

Ricardo

User avatar
garvinhicking
Core Developer
 
Posts: 29463
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany

Postby garvinhicking » Sun Jun 26, 2011 11:56 am

Hi!

This oauth class requires php5, and it seems your provider runs php4? Check if you can enable php5...

HTH,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

ricardob
 
Posts: 2
Joined: Sun Jun 26, 2011 1:01 am

Postby ricardob » Sun Jun 26, 2011 11:58 pm

Strike!

The server is running version 4.4.9 - that is most likely the reason...

I was thinking is was already updated to 5.x ... hmm.

Thank you for the advice!

User avatar
blog.brockha.us
Regular
 
Posts: 695
Joined: Tue Jul 03, 2007 3:34 am
Location: Berlin, Germany

Postby blog.brockha.us » Sat Nov 26, 2011 9:11 pm

@garvin: What is the reason the OAuth code needs PHP5? If it is like that, we should change the meta info for the plugin (or change the code). Don't you think so?
- Grischa Brockhaus - http://blog.brockha.us
- Want to make me happy? http://wishes.brockha.us/

User avatar
garvinhicking
Core Developer
 
Posts: 29463
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany

Postby garvinhicking » Mon Nov 28, 2011 2:22 pm

blog.brockha.us wrote:@garvin: What is the reason the OAuth code needs PHP5? If it is like that, we should change the meta info for the plugin (or change the code). Don't you think so?


Definitely. I just changed it.

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
blog.brockha.us
Regular
 
Posts: 695
Joined: Tue Jul 03, 2007 3:34 am
Location: Berlin, Germany

Postby blog.brockha.us » Tue Nov 29, 2011 1:58 pm

The code or the meta info?
- Grischa Brockhaus - http://blog.brockha.us
- Want to make me happy? http://wishes.brockha.us/

User avatar
garvinhicking
Core Developer
 
Posts: 29463
Joined: Tue Sep 16, 2003 9:45 pm
Location: Cologne, Germany

Postby garvinhicking » Tue Nov 29, 2011 3:58 pm

blog.brockha.us wrote:The code or the meta info?


The meta info; the PHP5 requirement is IMHO quite hard due to json_encode and some XML things.

Since s9y 1.7/2.0 will also require PHP5 I don't see any use in spending time to PHP4-backport anything now.

Regards,
Garvin
# Garvin Hicking (s9y Developer)
# Did I help you? Consider making me happy: http://wishes.garv.in/
# or use my PayPal account "paypal {at} supergarv (dot) de"
# My "other" hobby: http://flickr.garv.in/

User avatar
blog.brockha.us
Regular
 
Posts: 695
Joined: Tue Jul 03, 2007 3:34 am
Location: Berlin, Germany

Postby blog.brockha.us » Wed Nov 30, 2011 12:43 pm

Well.. For JSON I've added a "compatibility class" doing all the JSON stuff on PHP4 environments 2 years ago.

But sure: If s9y itself will need PHP5, there is no use in wasting time thinking about PHP4. And I think there are not that many PHP4 environments any more anyway. The last one I knew (rowi) is PHP5 already, too.
- Grischa Brockhaus - http://blog.brockha.us
- Want to make me happy? http://wishes.brockha.us/



Return to Plugins

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron